Possible bug in MyOSMC plugin with codec handling

I have in my config.txt added multiple codecs for more pi
After booting both codecs was enabled.
When I browsed to My OSMC plugin ti Pi Config section for checking of codecs status in GPU Mem & Codec page and cancel this page I received the note “Changes to Pi config requires a restart”
But I change nothing and push Cancel.
If I checking config.txt after this action, I found deleted all other codec numbers and stay only first one codec in line.
If I put this SD card to another Pi, the codecs was disabled
Logs after this operation:
Does anybody have also this strange behaviour ?


You’ll find codecs enabled once they’re set once anyway. After they’ve been input once, you never have to put them in again.


CC @Karnage

The codec info is no longer needed in config.txt if I remember correctly, so if the codec licenses disappeared, it shouldn’t matter. You could always add them back to be safe.

The codec license is Pi specific, so the license will not work if you take the SD card and put it in a different Pi.

Read the post quickly, so didn’t give the correct advice originally.

That’s expected. Licenses are purchases on a per-Pi basis.

Maybe I explained bad
there are 2 problems:
My original lines from raspberrry pi shop which I added to config was pi specific:

When I open Pi Config in MyOSMC it was changed to:

In PiConfig I push Cancel not OK
I didnt change anything, but config was changed by MyOSMC