Possible sound bug?

This week I was using the RCA out and noticed when playing shows and having it set to go to the next video automatically, that every time it did that (tested on multiple different shows and seasons) there was an echo (like it was duplicating the sound, but one was a little slower. I had the output set to both hdmi and analogue out, but only was using RCA at the time it happened.

I was on the beta 1 build not the newest build, so not sure if the newest fixed it or not, but just something to test.

Hmm, there is no Beta 1 build, do you mean RC1 ? (Actually called just RC)

If so, please try updating to RC2 via OSMC settings and see if you still have the same issue, as RC2 has a new build of Kodi.

Yeah, sorry. I meant RC1. I have updated to the newest today, but don’t have a way to test ATM since I only had a way to test RCA this weekend. Hopefully someone else can test for me.


I am also having this exact same problem. I have the following setup:

  • Raspberry Pi 2
  • OSMC latest release version (2015-06-1)

The problem only seems to start occuring when watching a TV series continuously. The first episode in the queue usually plays fine, however the subsequent episode has an audible echo throughout. I’ve tried through HDMI and RCA output but the same on both.