Posterisation on "World in HDR" at 1080p

So, I don’t really care about this :smiley: but as it’s apparently unexpected behaviour, I thought you might want some logs to look at.

I’m playing the test clip called The World in HDR (HEVC version). It plays fine at 4K, but if I switch resolution to 1080p then all of a sudden I’m seeing the kind of posterisation/banding that I associate with 8-bit output instead of 10-bit. The output signal is still 444 10-bit, but the banding is unmistakeable.

Here are some logs. Playback starts at 2160p then I switch manually to 1080p later. Other methods for playing it at 1080p (such as de-whitelisting 2160p modes or setting Adjust Refresh Rate to off before playing) produce the same effect.

This is my go-to clip for testing HEVC and HDR and I didn’t see anything amiss pre-update.

Never tried it at 1080p though.
Will be in-front of a TV in a couple of weeks. Until then, not sure.

I just had a play and have no problem playing it with my GUI set to 1080p60. Surprisingly, though, if I set the GUI to 1080p50 and turn off adjust refreshrate I don’t get HDR. That could give some banding by using gamma rather than PQ EOTF even at 10 bits although I can’t say I could see any.

It doesn’t look like you had that setup in the logs - difficult to tell when and how you changed resolution.

I changed resolution via the OSD while I was logging. But I had previously tried the effect of de-whitelisting all 2160p modes, and of changing the desktop resolution to 1080p/59.94 and then turning off “Adjust display refresh rate”, and I got the same banding effect both times.

I would take a screenshot for you, but (as discussed in the other thread!) since moving to the staging repository, I’m having additional problems with this clip. Once the staging build is straightened out we can come back to this if you like.