Power issues with Vero 4k+

Hi - I bought a Vero 4k+ to replace a WD TV Live. My requirements are to be able to connect to either a network SMB share or a Linux export, and to be able to handle large video files and HEVC/x265 encoding. Seemed like the Vero would fit the bill.

As background, I’m very familiar with Linux; I have several Debian boxes here doing various things, but I know almost nothing about Kodi, etc.

I’ve noticed that my Vero does not seem to be reliable at all. As a side note, it would be very handy if it came with some sort of case light that would tell me if it thinks its powered on. Maybe a future feature.

Anyway, the Vero is always powered on and connected. I can get it to work just fine (still need to figure out a good way to handle subtitles, but that’s a separate issue), but every now and again I will turn on the TV and there will be no display from the Vero box. Nothing, no remote button seems to do anything. So, I unplug the power cable, count to five, plug it back in. I get the red cross on the front for a few seconds, I get a small OSMC icon on the screen, I get a blue screen with the OSMC logo, and then the display completely blanks. Nothing. I repeat the power cable trick, same thing. Only after a non-consistent number of attempts at unplugging/plugging do I get the menus and everything seems to work fine again (until it doesn’t).

Does this sound like a known issue? I’m happy to SSH to the box and look at whatever log files people might suggest to help troubleshoot this.

My first reaction to my Vero was that it seemed great; these power issues, if unresolved, would cause me to completely reverse that opinion.


I’m sorry to hear you’re experiencing a problem.

What peripherals are attached to the device?

This doesn’t sound power related to me.

If you can login via SSH and run grab-logs -A after reproducing this issue, it should allow us to see what the issue is.


Yes. A few people have reported something similar. Seems to depend on the attached AVR/display. There’s fix in the next OSMC release which will be available ‘real soon now’. If you can post logs we can check if that’s what’s happening in your case.

Early Veros had that but users complained.

What peripherals are attached to the device?

Just a 58" Samsung plasma TV. The next time it happens (which won’t take long) I’ll run grab-logs, thanks.

If you can post logs we can check if that’s what’s happening in your case.

Will the “grab-logs” suggestion suffice for this?

Early Veros had that but users complained.

That’s… interesting. Yes, that’s the word I want to use.

grab-logs -A and post the resulting URL here.

grab-logs -A and post the resulting URL here.

So, I wasn’t entirely truthful. The Vero box is connected to a Denon A/V receiver, which has the TV as its output. Mentioning that just in case it might be relevant.

I powered on the receiver and TV to check it just now, and was confronted with a blue screen and a message about something failing to play (even though I hadn’t tried to play anything). I could take a picture of the screen with my phone if there’s a way to upload a photo here. If I’m understanding the screen correctly, it tried to play a very long filename starting with comp_LA_A009_C009, which is a filename that means nothing to me. The Vero box seems to be completely unresponsive to the remote. I can SSH to it, so I logged in and ran grab-logs -A. It seemed to take approximately forever, but eventually returned https://paste.osmc.tv/.

Holding off on a power recycle in case there’s anything else I should be doing beforehand.

The logs are empty meaning they were probably larger than the maximum allowed size of 10M.

You could always just update to the latest version which we’ll be releasing soon anyway.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating. This will return you to the normal update channel. To remove the file:
sudo rm /etc/apt/sources.list.d/osmc-devel.list. Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

echo ‘deb http://apt.osmc.tv buster-devel main’ | sudo tee /etc/apt/sources.list.d/osmc-devel.list

This echoes the first part of the command (before the pipe) to the command line, and a cat of osmc-devel.list seems to show the source added.

apt-get update returns with no apparent error. Same with apt-get dist-upgrade.

Box rebooted, I now have the menus up. Will let you know if I see anything untoward.

Thanks very much for the help.

You are very welcome. Keep us posted.