Power settings with External Drive

Installed no problem, then this:

Seems you mistyped the “’” and used “`” instead.

Generally as you use putty you just can copy and paste the command from the browser to avoid that.
Command should be watch 'lsof | grep media'

The result of drive state is: unknown is not good because it coud indicate that the enclosure is not allowing any external power commands to the drive. While you still could try to run hdparm -y /dev/sda and/or hdparm -Y /dev/sda and hear if the drive powers down.

Thanks for the info, but it is a bit strange how/why that software would block private IP addresses.
Anyhow strange things happen in this world

Copied and pasted:

hdparm

Ok, the hdparm output is the one I feared. Means the enclosure doesn’t listen to the external commands that the Vero sends. So you only can rely on the own power management of the drive which as you have tested also on the other machine seems not to work.
So overall there is not much you can do to spin the drive down.

On the output of lsof was suprized to see mediacenter there as I haven’t seen that on my system but it might have been just a momentarily snapshot.

You have to sudo that watch command to see the external drives activity.

Well not the watch command but the lsof command. Means watch 'sudo lsof | grep media'
But that would be needed for the content of /media which is accessible by osmc user

Ok, acutally now I figured why your output differed from mine :wink:
For another problem solving I am doing in the moment I stopped mediacenter (stupid me).
So I think my orignal one watch 'lsof | grep media' should still work and just ignore the few mediacenter entries.
So if you run that command for 5 minutes question is if any additional open files on your external drive pop up.
But to be honest I think we are chasing ghosts and should just life with the spinning drive or have a proper NAS setup.

I agree with you. I think we’ve gone down this rabbit hole far enough. 2 other quick questions.

  1. Can you plug in a drive while Vero is on?
  2. Do you recommend shutting down Vero to unplug a drive?

I’m definitely going to learn how to set up NAS. If you can recommend any tutorials, videos, websites or books for beginners that would be great. My main concern is allowing read only access to the movies and files, no deleting or making any other changes from other computers or devices.

I want to thank you and everyone else for all the help. I’ve learned a lot but still have much more to go. I’ll be posting some other questions as I dig deeper into Vero and Kodi. Thanks

Yes

Generally an safe eject should be good enough but shutdowing would not harm.

Well user rights depends on which NAS you buy and which network protocol you use.
As a starting point you could connect the USB Disk to the Vero and install the SAMBA server from the App Store. But the default configuration of the Samba server does not apply different permission as it is designed for a plug and play user solution.

Suggested read up

https://www.ixsystems.com/community/resources/freenas-and-samba-smb-permissions-video.8/

I’ve got some reading to do, Thanks

If you wouldn’t mind humoring me one more time I would like you to take that WD and set the sleep timer in WD utilities to 30 min. Plug it back into the Vero and check it when the Vero has been idle for at least 30 min. Don’t pay any attention to a status light on the front of the drive if it has one. You should be able to hear if it is spinning or not if you put your ear up to it.

If you happen to have accessed that drive over the network with a Windows 10 computer I would also like you to either not use it during the test, or go to the Windows settings->personalization->start-> and turn off the “show recently opened items in jump lists…” then turn it back on.

I’ll give it a test and let you know.

Drive is not networked yet.

1 Like

I wasn’t talking about a full network setup. If you have SMB installed on the vero you can access the drive over the network. If you have not done that then you don’t have to worry about it. Otherwise Windows makes a shortcut to files you opened and for some reason decides it needs to check the files are still there whenever you access a quick launch screen. It doesn’t bother doing anything with dead network links but… :man_shrugging:

So I set both the Seagate and WD drives back to 30 minute sleep. I connected the Seagate and checked it after about 40 minutes and like you said the light was on, but I couldn’t hear the drive spinning or when I picked it up I didn’t get that gyroscopic feel you get when the drive is spinning. So I’m wondering if it’s just the drive going into sleep mode from it’s own settings or is the sleep also induced by a Vero command?

Have not checked the WD drive yet, but I’m sure the same results will occur.

Thank you. Unfortunately I don’t think that drive is going to actually stay asleep as it should. I believe I have managed to reproduce and i’m interested in figuring out a solution and i’ll let you know if I am able to.

Final update on this topic, and i’m only going to give the TLDR version. I’m fully satisfied that the way the power settings are configured in OSMC are the least bad settings available. Most drives should spin down just fine (after 20 min of inactivity) and the ones that don’t it is a matter of debate on if the drive or Debian to blame (it is probably the drive).

With my particular drives I was testing (WD MyBook and Easystore) the ones that were never messed with sleep just fine with a nice blinking light to let me know they are asleep. However once I used WD Drive Utilities to change the sleep time the drive presented itself, and interacted with the OS, in a very poor fashion. Unfortunately this is also not easily (if at all) reversible (thanks WD). The solution for this particular drive was to go back to WD Drive Utilities and turn off the sleep settings. This does not get the drive back to a blinking light (sleep) but it does get the drive to spin down perfectly, and that is close enough to the same thing for all practical purposes. With the drive set to any other setting the sleep function was not reliable.

2 Likes

Here’s an article that helped me superbly: Spin Down and Manage Hard Drive Power on Raspberry Pi

I learnt my external USB HD—a “Seagate 1 TB BarraCuda Pro 2.5 Inch” put in an Inateck enclosure—was incompatible with hdparm; I had to resort to hd-idle and finally managed to spin down the hard drive after 10 min. In fact, any amount can be set.