Powered Hub Not Powerful Enough?

I have a Vero 4K with a powered hub connected to one USB port and the receiver for a remote control plugged in the other (all 3 bought from here). The USB hub has a Hauppauge WinTV-dualHD dongle and a 4TB portable HDD connected.

My previous 1TB HDD was behaving strangely and I thought it was failing so I bought the 4TB one but that is having issues too. It seemed fine earlier but now it has disappeared and isn’t listed by blkid. The light on the HDD case is blinking and the disk is spinning though (I can feel it vibrating and it’s not making any funny noises). Also, the Vero won’t boot up with the drive connected, it seemed to be in a loop but the output just looked like a lot of random numbers to me.

Is it likely to be a power issue? I can upload some logs tomorrow if needed.

If the Vero won’t boot with a drive connected to a powered hub then it may be that the powered hub is no longer powered. That, or the spinning rust combined with the tuner is drawing more than the hubs power supply is currently able to supply.

1 Like

Is this an OSMC powered hub?


Thanks for the replies.

The drive is definitely getting some power but I don’t know if it’s enough or not.

Yes it is an OSMC powered hub.

I’ve tried plugging the hub into the other USB port on the Vero and tried plugging the HDD into a different port on the hub. I’m using the power supply that came with the Vero. t’s actually a 4K+ not a 4K.

dmesg says:

[93972.638541] sd 0:0:0:0: [sda] Attached SCSI disk
[93979.197410] usb 1-1.4: new high-speed USB device number 11 using xhci-hcd
[93979.428060] usb 1-1.4: New USB device found, idVendor=1058, idProduct=2621
[93979.428069] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[93979.428073] usb 1-1.4: Product: Elements 2621
[93979.428077] usb 1-1.4: Manufacturer: Western Digital
[93979.428080] usb 1-1.4: SerialNumber: 675832324432334350445469
[93979.428769] usb-storage 1-1.4:1.0: USB Mass Storage device detected
[93979.431777] scsi host0: usb-storage 1-1.4:1.0
[93980.488018] scsi 0:0:0:0: Direct-Access     WD       Elements 2621    1034 PQ: 0 ANSI: 6
[93980.489604] sd 0:0:0:0: [sda] Spinning up disk...
[93980.490138] sd 0:0:0:0: Attached scsi generic sg0 type 0
[93981.527341] .................................................................................................not responding...
[94093.364871] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x00 driverbyte=0x08
[94093.364882] sd 0:0:0:0: [sda] Sense Key : 0x2 [current] 
[94093.364888] sd 0:0:0:0: [sda] ASC=0x4 ASCQ=0x1 
[94095.364756] sd 0:0:0:0: [sda] Test WP failed, assume Write Enabled
[94097.364749] sd 0:0:0:0: [sda] Asking for cache data failed
[94097.364758] sd 0:0:0:0: [sda] Assuming drive cache: write through
[94097.372523] sd 0:0:0:0: [sda] Spinning up disk...
[94098.405009] ..............................................................not responding...
[94343.950621] sd 0:0:0:0: timing out command, waited 180s

Have you tried just powering the drive and nothing else?

  • I shut down the Vero and powerd it back on with only the HDD connected to it. It booted fine and I could access the drive.
  • I shut down the Vero and powerd it back on with only the the hub connected to it and only the HDD connected to the hub. It booted fine and I could access the drive.
  • I shut down the Vero and reconnected the remote control dongle to it and the TV dongle to the hub. It booted fine but cd /mnt/storage resulted in -bash: cd: /mnt/storage: No such device and I can’t access the TVheadend web interface.

I have also changed the fstab entry from using the label to using the UUID and changed the auto option to x-systemd.automount in the hope that it would prevent a boot loop.

Can you post a log?


Here’s the log.
I was uploading some files to the HDD using scp when it disconnected so that’s when I’ve done the logs from. I’ll upload the logs right after a fresh boot too though if that’s more helpful.

Something might be a bit dodgy with that enclosure. Could you check the cables / see if you have another enclosure?

Do you mean enclosure for the hard drive? I’ve not got another enclosure but I’ve had a similar problem with two different drives. The current one is a new 4TB one; should I try again with my old 1TB one?

Does it make any difference, if you operate the hub with/without the associated power supply unit?

I have only tried it with the hub connected to the mains so far. I can try it unplugged from the PSU later but I think it might not actually be the hub after all.

We were watching something on the Vero just now. The only things plugged in to the Vero were the PSU, ethernet and HDMI cables, remote control dongle and a 16GB USB stick. The file we were watching was on the USB stick. We got about an hour through and playback stopped with a message saying something about the file being unavailable. I checked via ssh and the drive had disappeared. I rebooted and tried to fast-forward the file to where we were and the same thing happened again. I rebooted again and this time we were able to watch to the end. I’ve got the log from shortly after this happened.

In theory, If the PSU on your hub had failed the power for all devices would then land on the PSU for the Vero itself. The current draw required to power the Vero, hub, a hard drive, and tuner is likely more than what the Vero’s PSU is rated to supply. This situation could then damage the Vero’s PSU such that it is no longer able to supply its full rated power as it once had. I would try another PSU connected to the Vero or if you have a usb male A-A cable back power it from USB instead of the barrel jack for testing purposes.


Before getting the hub, I had the TV tuner and a hard drive plugged into the Vero so perhaps that damaged its PSU. I’ve just ordered a replacement PSU for the Vero from here and I’ll report back when I’ve tried it. Thanks to all for the help so far!

1 Like

Forget my previous post. I’ve noticed that one of the blue LEDs that light up when a port is switched on on the hub doesn’t light up. I’ve plugged the HDD in the port furthest from the one that’s not lighting up and I was able to copy some large files to it without error. However, the dive kept making a clicking noise so is it OK to use like this or is it likely to damage the drive? If I need to buy a more powerful hub, any recommendations?

If there’s a clicking noise it sounds like the drive is struggling. This might not be a power issue but a mechanical issue with the drive. It’s worth checking on another device.

It’s a new drive and seemed to be working fine connected to the computer. I’ll check it again though.

The clicking is common with mechanical hard drives that are underpowered. It is NOT advisable to use a drive like this. In theory, there shouldn’t be a way to cause physical damage from this as the auto head-parking systems have been robust for decades now, but getting data corruption from this is very much a strong possibility.

As for a more powerful hub I would make sure that whatever you get is USB 3.0 or faster in addition to just being self powered and also using a properly rated cable if not using the one supplied with the drive as this should assure the hub is allowing the higher current output that the newer specs allow for.