Priority of wireless networks

Hi, long time no see, just used osmc on some rpis 2 b and everything went smooth thorugh so far… The problem is i have added the wireless information for the network. I had the same issue as in another topic that it said 30 times wrong password as i was sure it was the right one…This was resolved with powercycling the rpi. Now the wireless works but at a friend there is an open network available. The pi is automatically always connecting to the open one instead the one which is from my friend.

So i checked some posts and found the configuration via commandline. this worked for that moment… after reboot same issue.
So i think as the open network does not need credentials the pi saves it directly in its list …as i read 2 mins ago in /var/lib/connman/wifi_xxx_managed

so my question is how to prevent adding open networks automatically as preferred networks, or how to set the priority for a certain network manually?I thought of a simple hook in the interface defining the one as the preferred one or similar solution would be great
Any help appreciated. Thx

PS: awesome work on OSMC @Sam + Team


Wow, that is a name I have not seen in a while…

I don’t think we should join open networks w/o consent by default anyway. I believe there is a ConnMan setting to adjust this behaviour and if there is I will change the default behaviour

CC @DBMandrake



Thx Sam… would be great if theres a setting you tell me where i find that. my friend is calling me like crazy…he wants to use his osmc :smiley:

Connman doesn’t auto-connect to open networks unless you have previously connected to that open network manually - just tested it myself to double check.

Most likely you accidentally connected to the open network once which caused it to be saved. To forget the network simply select it when it is connected and choose ‘Disconnect and Forget’. I tested doing this and rebooted and confirmed it no longer connected to the open network.

BTW are you up to date ? The networking GUI has changed quite a bit between RC2 and RC3 and again to the final release - in older versions once you connected to a network it was impossible (via the GUI) to forget a network, only quite recently was Disconnect and Forget added, so make sure you’ve updated to the final 2015.06-1 release.

Hi DBMandrake,

It looks like it is old version… yes i agreee with you… It was installed by noobs installer which pulled the install somewhere from net. I dont have the forget option so yes im sure it is old here.

i also tried the update options which didnt give me an available osmc update.
I think i will fresh reinstall and see if its resolved. Sry bothering you guys with old stuff already resolved.

NOOBS is RC3 at the moment and I think the earliest version we ever shipped was RC2 if memory serves. Both of which are upgradable to the final version.


How can you get OSMC to forget a network it previously connected if you are not currently connected to it. i.e the PI2 in it’;s new location always shows previously saved/connected networks.