Probelms playing back AVC file (FULL HD, 25p)

Hey Sam and OSMC team,

I have a problem playing back an AVC file via my Vero4k+.

The file is a 1920x1080, 25.000 FPS AVC videofile. It stutters when played via my Vero4k to my 4K Sony OLED. Playback works flawless on my computer.

The first thing I noticed is that I can’t find the resolution of 1920x1080 at 25 FPS in my resolution whitelist. I tried to enable FPS doubling and whitelistet 1920x1080 at 50 fps, but it still stutters.

I enabled Kodis logging and started the videofile again. It shows that the file is played with 33 fps.

I uploaded the log:

Let me know I need to send you the file, too.

Deselect 3840x2160p25Hz in your whitelist then the file will play at 1960x1080p50Hz if that is whitelisted.

still doesn’t work. The fps shown via the kod onsceen jumpst between 30 and 34 fps instead of a fixed value of 25fps…

here is a testfile. Could you try it?

btw, I am up to date with the latest vero4k+ software.

i tried it on my second device (vero4k+) and there it works flawless. I will try to reinstall my main vero and see if that helps…

I did a comlete reinstall of my vero and it did not work. The problem still exists. On my second vero with my lg tv, the resolution 1920x1080 at 25fps is shown in the whitelist and it works flawless. On the main vero this resolution is not available in the whitelist. Is there a way to add/force this resolution or make it available?

What would it help to force a resolution/fps that your TV doesn’t support?

My TV supports 1080p25… don’t know why it doesnt show it under the whitelist…

If it does, it’s keeping quiet about it:

====================== Display Cap CTA =================== g0gjk991

---------------------- Display Cap CTA END --------------- g0gjk991

You should also be able to see 73 in the long line of numbers in the EDID in your log. But it’s not there.

strange… but even if it would not support it, why doesn’t it work with doubled fps in 1080p50 mode? And how could I force the vero to upscale the file to 2160p25?

I don’t know. Usually 1080p50 is best for 25p material, especially for interleaved. Your clip (progressive 25Hz) plays fine here at 1080p50. Do you maybe have some network issues? You are using Kodi’s in-built smb to connect to your server which is not as performant as using the operating system (fstab or autofs) to connect. Why that should affect only this video (does it?) I couldn’t say. Try playing that clip from a local drive (eg USB stick) and if it’s OK, look at different ways to set up your network connection.

That’s what it was doing when we started this conversation and it’s not optimum

2022-01-22 13:33:38.315 T:2711     INFO <general>: [WHITELIST] Searching the whitelist for: width: 1920, height: 1080, fps: 25.000, 3D: false
2022-01-22 13:33:38.316 T:2711    DEBUG <general>: [WHITELIST] Searching for an exact resolution with an exact refresh rate
2022-01-22 13:33:38.319 T:2711    DEBUG <general>: [WHITELIST] No match for an exact resolution with an exact refresh rate
2022-01-22 13:33:38.319 T:2711    DEBUG <general>: [WHITELIST] Searching for an exact resolution with a 3:2 pulldown refresh rate
2022-01-22 13:33:38.322 T:2711    DEBUG <general>: [WHITELIST] No match for a resolution with a 3:2 pulldown refresh rate
2022-01-22 13:33:38.322 T:2711    DEBUG <general>: [WHITELIST] Searching for higher resolutions with the exact refreshrate
2022-01-22 13:33:38.324 T:2711    DEBUG <general>: [WHITELIST] Matched fuzzy whitelisted Resolution 3840x2160 @ 25.00 - Full Screen (34)
2022-01-22 13:33:38.324 T:2711     INFO <general>: Display resolution ADJUST : 3840x2160 @ 25.00 - Full Screen (34) (weight: 0.000)

The file plays fine via USB on my TV, so I think the resolution is supported and not the problem and I dont think the network is the problem. Every file (even UHD high bitrate MKVs are playing fine and the file plays fine on my second vero with the LG tv on the same network…

could this be a false detection of the supportet resolutions or a broken edid information? everything else plays fine so far.

Which resolution? 1080p25hz is very likely not supported by your TV. Which TV is it exactly?

Sony 77A84J

As expected doesn’t support 1080p25Hz

HDMI™ signal :4096x2160p(24,50,60Hz), 3840x2160p(24,25,30,50,60,100,120Hz), 1080p(30,50,60,100,120Hz), 1080/24p, 1080i(50,60Hz), 720p(30,50,60Hz), 720/24p, 576p, 480p

So chasing that path doesn’t make any sense. So you should be focusing why it is not playing at 1080p50Hz

ok. But why does it work via USB then?! And why does 1080p50hz not work?

So when you playback via USB your TV OSD shows 1080p25Hz? Would be strange but could be it supports frequencies via it’s internal player that it doesn’t support via HDMI.

That is the more crucial question to figure out especially as @grahamh wrote the file plays as 1080p50hz on his setup. Have you tried with an empty whitelist?