Problem connecting to my vero 4k

I try to ssh into the device and I pet the error that connection refused

What’s the ssh port ?

I can connect with kore remote to device without a problem using the ip 192.168.0.15

22 is always the default unless you changed it.

Some logs would be helpful if you continue to experience issues.

Will provide them later as the vero I’m talking about is not the one I have at home

image

Can’t read that.

https://paste.osmc.tv/umoviwocol

Logs look fine. So what is happening when you are connecting via SSH? Any error or just not connecting?

What happens with verbose mode ssh -v 192.168.0.15?

At the location where this vero is used I don’t have a pc and I don’t own a laptop so I’m using Terminus on my iPad to ssh. https://eugeny.github.io/terminus/

It gives the error connection refused

If I use the same app to ssh into my vero at home it works just fine

Might be an issue with terminus not supporting the SSH encryption keys.
Would compare the sshd.conf on both machines (means for the one that you can’t access via SSH you would need to login locally at the console.

Thanks! I’ll see what I can do. In the worst case scenario this vero will have to wait for buster/new kernel/ new video stack until I can update to it without editing the sources list.

I discovered the problem when I tried to ssh in to edit the source list as advised in the new video stack thread

I can see nothing in the log which suggests that sshd started. It might have been disabled in some way, in which case remote access won’t be possible.

1 Like

You are right, I got misled by the avahi ssh entry.
There is no start of sshd in the log.

Could I have disabled it in the GUI ? By accident?

I might have disabled it by accident thinking I’m disabling access over the internet and not locally

Yes, check under MyOSMC - Services