Problem Finding External Hard Drive

I keep a backup of my music files on a 1 Terrabyte WD easydrive.
I have a Vero4K running 19.1. I’ve recently started using the Vero4K to play music stored on a NAS.
I’m getting occasional stuttering during playback which I assume is due to network delays, so I thought I’d plug the easydrive into the USB port on the Vero and see if that was better.
My problem is embarassingly simple. When I go to Add Music under Media I can’t find the drive.
I’ve tried to find guidance in these pages, but all I can glean from them is that I may need to connect my drive via a powered hub. I’ve just tried doing that and it made no difference.
I must be missing something really simple. Can someone help, or tell me where this simple connection is documented? Please don’t tell me to start using Linux commands.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Choose root Filesystem and then media. If you still can’t find the disc upload logs as indicated above

I thought my problem was embarassingly simple. The solution was also. What I did to cause the problem was too stupid for me to admit in this forum.
If anyone looks at this post for a solution - just plug your drive directly into one of the USB ports on the Vero4K and look for it under auto-mounted drives.
I apologize for wasting the time of whomever was kind enough to reply to my earlier post.

Ideally – you’ll want to use a powered hub if your drive doesn’t have its own power supply.