Problem playing files from NAS

Hi All

I have just setup OSMC RC on a new RPi 2 for the first time.
All media is stored on a local NAS (LG) which I have setup to be accessed using SMB (using IP address).

OSMC can see the NAS directories and I have scanned both movie and TV shows without a problem although they took a while.
The problem is they won’t play! I can browse movies and TV Shows fine but sometimes it pops up with ‘Unable to open file or files’ box and others it looks like it’s going to start but does not and just returns to the list.

This is for all video types (mp4/avi/mkv).

I have a few other Kodi installs on Win 7 machines, Android and also a previous RPi B+ running Raspbmc on the same network which can all access/play the NAS Media without problems.

Other info…
Network is wired - currently using DHCP as manual would not connect.
I am using Kingston 32GB SD Card (on approved list) - Have also tried 16GB.
Playback from a USB connected to Pi is fine.

Log files are located here:

Any help would be much appreciated.


17:20:42 T:1659085856 ERROR: ffmpeg[62E3A420]: [mov,mp4,m4a,3gp,3g2,mj2] error reading header
17:20:42 T:1659085856 ERROR: Open - Error, could not open file smb:// (2014).mp4

Do other files play, I see where this file failed twice but no other files were tried


No other files will play. I had re-installed a couple of times so only one showing here.
This includes avi and mkv etc.


try FTP or NFS… samba can be a bitch and have an overhead in both ends.

FTP has the same problem. My Nas does not have NFS unfortunately so I could not try that.

I have also tried playing video from a WIn 7 PC and this also fails! Adding source and browsing is fine.

Any other ideas appreciated.


I have what seems to be a similar problem – no problems getting directory listings over SMB but playing a file seems to sometimes work, sometimes not work. When it doesn’t work I get “ERROR: Open - Error, could not open file”

If I copy the video files onto a USB stick and plug it into the RPi the files play just fine so I know it’s not an issue with the files themselves.

OSMC on Raspberry Pi B+ 1.2, Kodi 16.0.

Debug log at

Any help much appreciated :surfer:

How are you connected to the LAN and can you do a throughput test with iperf?

Thanks for replying.

The RPi and the SMB server (a Windows 7 machine) are both connected via WiFi (not ideal I know but hard wiring isn’t practical).

I did a 60 second test with iperf3 with results recorded at 5 second intervals. The results are at

The network performance looks to be poor, which is a little surprising because in the past there have been occasions when videos have streamed without issue. Perhaps there are environmental factors intermittently affecting the WiFi throughput.

Would bad network performance lead to “ERROR: Open - Error, could not open file” though? I would have thought if network throughput was the issue then the file would begin playing but would just stutter or frequently buffer.

Yes - if you look at your log files, you’ll see loads of errors where connections have actually timed out because the connection was so slow :frowning:.


16:58:54 335633.875000 T:2821452784 ERROR: SMBDirectory->GetDirectory: Unable to open directory : ‘smb://USERNAME:PASSWORD@a8-7650k/video/tv%20shows’
unix_err:‘6e’ error : ‘Connection timed out’
16:58:56 335635.781250 T:3024810544 ERROR: GetDirectory - Error getting smb://a8-7650k/video/tv shows/
16:58:56 335635.812500 T:3024810544 ERROR: CGUIMediaWindow::GetDirectory(smb://a8-7650k/video/tv shows/) failed
16:59:03 335643.343750 T:2744120304 NOTICE: ES: Client from timed out

Yes, with that performance you will get timeouts that leads to not be able to open.

Install wavemon to try to figure out what’s the issue on your wireless connection.