Problem playing some x265-encoded videos, possibly permissions thing and then some

I have a server running TrueNas where all my media is stored. I have NFS shares created for those folders. The share is /mnt/pool1/media
I created a mount point through fstab on the Vero’s side, /mnt/Skladiste

As far as I can tell, everything is set up correctly, but it wasn’t until today when I was digging in the library after replacing some remuxes with x265 encodes and noticed that some films just wouldn’t play at all. They mostly seem to be from the x265 group, but I have only tested a few.

That’s the problem in a nutshell, but when I was going through the log, I noticed the system running Vero apparently has no unicode support, because stuff like this makes no sense: “/mnt/Skladiste/dokumentární/”. It should say “dokumentární”. I have no idea if that is relevant to the playback problem or not.
So that’s either problem 2 or whatever.

I asked on reddit and someone told me there is likely to be a permissions problem according to the logs, but that makes no sense to me since most/majority of the files do play correctly.

I have completely reinstalled the player to eliminate any other possible sources of errors and only configured some basic stuff, added the mount point from SSH and only added the folder with films for the purpose of troubleshooting.
The library scanned the files seemingly fine (some files are missing but I will create another thread for that problem once I solve this).
I tried playing one of the problematic files and then generated a log.

Here is the log:
(it complained about term.log and history.log missing)
Here is Mediainfo about the file I tried to open:

Just to follow up: there’s some previous discussion here,

I think for unicode, you would need iocharset=utf8 in your fstab mount.

2021-02-04 21:08:54.975 T:3105046752   DEBUG: CFileCache::Open - opening </mnt/Skladiste/filmy/Predator (1987)/Predator.1987.2160p.UHD.BluRay.X265-IAMABLE.mkv> using cache
2021-02-04 21:08:54.977 T:3105046752   ERROR: Open - failed to open source </mnt/Skladiste/filmy/Predator (1987)/Predator.1987.2160p.UHD.BluRay.X265-IAMABLE.mkv>
2021-02-04 21:08:54.977 T:3105046752   ERROR: CVideoPlayer::OpenInputStream - error opening [/mnt/Skladiste/filmy/Predator (1987)/Predator.1987.2160p.UHD.BluRay.X265-IAMABLE.mkv]

The file you attempted here does not appear to have any unicode, so I doubt that that is the problem.
While SSHed in, try:

ls -ld /mnt/Skladiste/filmy/Predator \(1987\)
ls -l /mnt/Skladiste/filmy/Predator \(1987\)

and post the output.

Permissions problem. File is owned by nobody and the group is just strange. Check the files on the server. In particular, check the owner/group and compare to files that work. Or you could try using the uid/gid options in fstab, but I think that you really need to fix it on the server.

Hm, then it must have something to do with the user/user id on the Vero side doesn’t correspond to the one on the NAS.
The owner of the entire share is user octopuss, who has id 1000 or something like that I think.

But how do I go about that?
Or maybe I can just should create a group with the same name/id as the one on the NAS?
I am not much of a Linux guy.

The osmc user is 1000/1000, but the NAS is not sharing the file as that. You need to check the permissions of the individual file in question. I assume that the NAS is linux based, so run the same ls commands that you ran on osmc.

This is what the permissions look like on the NAS

So it’s not owned by 1000:1000. A simple solution (on the NAS) would be to:

chown -R 1000:1000 /mnt/pool1/media/filmy

That will change all file/directories to be owned by 1000 and the group to 1000.

Well the problem is that files are primarily created by another server - I actually forgot to mention this - basically, the files are on the NAS, but I have a seedbox running qbittorrent.
I have that one configured like this

Now this gets a little more complicated, because despite setting the owner of the entire share on the NAS to root, obviously when I download new torrent in the seedbox’s qbittorrent interface, the files are owned by qbittorrent-box user with id 112.
That leads me to thinking the only possible way to get the Vero the appropriate permissions ( I only need read) is to add a common group the other two servers have, specifically “torrent”, with id 1111, to the osmc user.

If the group is always going to be 1111, then you could create group 1111 on the Vero, and add the osmc user to that group.

Yup that’s what I’m thinking.

On the NAS, you could also map 112 -> 1000 on the NFS share. Creating the group is probably the easy solution. Or, you could always just give everyone read access to the files and r-x access to directories.

1 Like

The group did it.
Now I need to figure out why some of the films are not even added to the library.

Have you tried scanning again after fixing the groups? Sharing logs after a scan may help us spot the problem, but it’s most likely filenames.

It seems like everything is working.
I have some questions, but they are irrelevant to this discussion, so I consider it solved.

1 Like

Feel free to open a new post if you have separate issues and we will be happy to assist