Problem to disable Power Management for wifi dongle

Hey there,

I have problems to disable power management for my wifi dongle. Im using a raspberry pie 2 Model B with a TP Link Tl-wn821n and running the latest OSMC Version on it. I managed to connect to the internet by wifi, but after ~10 Minutes after booting, i loose the connection every Time. I think it might be the power management, but I need help fixing this.



sudo iwconfig wlan0 power off make these disconnections go away?

If so, can you post the output of dmesg, so I can identify the chipset and make sure power management is being disabled properly



I already tried this but I always get an error there:
sudo: iwconfig: command not found


Did you install wireless-tools first?

apt-get update
apt-get install wireless-tools


Are you sure the dongle is getting enough power? Are you seeing a rainbow-coloured square in the top right hand corner?

Did you set max_usb_current = 1? Have you tried powering the dongle from a (powered) usb hub?

Hmm the Problem is better now, I think it’s just Not getting enough power. Will try this out over the next days then!

Thanks for your help!