Problem to install May update

on my raspberry pi2 after dowloaded may update
it’s stop on light blu screen with “cheking for update to install”

Please help me

Well first would suggest if you can still access it via SSH. If that fails then your best bet is to reboot by unplug and replug.

i tried with terminal to enter
ssh but there isn’t responce…

do you said me that i have to remove and replace energy of my raspberry pi2 ?

Well alternatively you can try to connect a keyboard to try to get any reaction but from what you are saying for me it sounds only a power cycle might help

ok now i return on Osmc April 2027 207-04-01

What is the best way to install the update now?
I have to Try again with My OSMC?

My suggestion is via terminal if you have a keyboard installed otherwise via SSH.
Then use
sudo apt-get update
sudo apt-get dist-upgrade

1 Like

on terminal show this

Estrazione dei template dai pacchetti: 100%
Preconfigurazione dei pacchetti in corso
: Errore di input/outpute sincronizzare il file nuovo “/var/lib/dpkg/status-new”
E: Sub-process /usr/bin/dpkg returned an error code (2)

input/output error indicates a broken SD Card but maybe post logs to validate grab-logs -A

Logs available at

lug 02 15:15:28 osmc kernel: mmc0: timeout waiting for hardware interrupt.
lug 02 15:15:28 osmc kernel: [a80e8803] REQ< ada62954 10801
lug 02 15:15:28 osmc kernel: [a80e8803] CMD< 19 4bb8d0
lug 02 15:15:28 osmc kernel: [a80e8808] CMDD 8 200
lug 02 15:15:28 osmc kernel: [a80e8808] SDMA ada62a18 ad9eda10
lug 02 15:15:28 osmc kernel: [a80e880a] FCM< ada62954 ada629b0
lug 02 15:15:28 osmc kernel: [a80e880c] RSP  900 0

So either as I assumed your SD Card failed or you have another serious Hardware Issue.
My recommendation try a new (quality) SD Card first to see if it works.

but with April Osmc it’s seem to work…

I got to watch a movie and it works. Sd is already good quality sandisk

Try to write a big file onto the SD Card and check if it is healthy
cd ~
cp 100MBtest.bin 100MBtest.bin.copy
md5sum 100MBtest.bin.copy

The result of md5sum should be 681025d06b3fec0117efcd5f1d1d8002

here is the result

osmc@osmc:~$ cp 100MBtest.bin 100MBtest.bin.copy
osmc@osmc:~$ md5sum 100MBtest.bin.copy
681025d06b3fec0117efcd5f1d1d8002 100MBtest.bin.copy

Well that is really suprizing with all the errors in your system log.
Than my only guess could be that during the upgrade the corruption happen.
But without full apt knowledge nor fluent Italian I am out of suggestions here.

Or could you run into a power problem? What power supply do you use?

I bought a good power supply one year ago
KFD 5,25V 3A

Than unfortunately my two above comments still remain that I am out of ideas but definitely something wrong with your SD Card at time you tried to install the update.
You can check your dmesg -T if the same errors popped up in the time you downloaded the file.

i’ll tried to buy a new SD card
Unfortunately my OSMC installation procedure is longer because I also need to install the HIFI Digi + audio card sotware …

Maybe someone else reads this thread who has a better idea why the SD Card fails

Hifiberry Digi+ will work out of the box.

SD cards fail eventually. You most likely had some silent corruption and the problems with the card were only exposed when you updated, which has a lot of write heavy operations and changes a lot of system files.

I have the Same Problems, on My Raspberry Pi3,
I have mentioned in the following Thread.

Raspberry Pi3 Update from OSMC May 2017.05-2 to 2017.05-3 Problems

But found no solution yet.