Problem upgrading from pi to pi3

I currently have a Pi2 (Model B Revision 2.0) running latest version of osmc (2016.04-2) and was hoping to just pop my sd card into my new pi3 as others have done but Im having a problem. (Im currently using a micro sd adapter)

on power on boot is stalling on the rainbow screen, get one flash of the green led and a static red.

is there something else I need to do first? have tried doing an update via my osmc, also tried apt-get update to ensure everything else is updated.

Can you plug the card into the old one and provide grab-logs -A

You mean in the Raspberry? If that is the case you have a Pi1

Are you sure you have a Pi 2 ? The Pi 2 does not say revision 2.0 on the board - from memory it is revision 1.1 or 1.2.

Sounds like you have a Pi 1 B+. Please provide a photo of the bottom side of the board or a close up of the writing on the top side of the board to confirm.

apologies, I misread the table I was looking at to work out which version I had (I won it in a competition so wasn’t sure). it said to check the cpuinfo for the revision, its set to Revision : 000f

am I able to swap from a Pi 1 to 3 or do I need to do a fresh install?

Logs available at

You have a Pi1 and you will need to do a new install.
But you can save you settings with the backup tool and restore it after the new install

ok thanks


Ive just done a fresh install, backup/restore worked a charm :slight_smile: