Problem with bluetooth headphones

Hello.
After the December update the bluetooth headphones did not work anymore so also following forum suggestions I returned to Osmc october 2017.10-1. From that date until a few days ago the Aukey EP-B40 Bluetooth headphones worked perfectly. Now the headphones broke and I had to replace them with the new model but still the Aukey EP-B40.

From MyOSMC I removed the previous headphones and made the pairing with the new model. The headphones have been recognized perfectly. In audio settings I re-set from HDMI to ASLA and the audio works properly.

The problem is when I turn off my headphones and turn them back on for a new listening. Unfortunately, nothing is heard as long as I do not return to audio settings and carry over ASLA-> HDMI-> ASLA. Among other things this thing often does not work and often must restart.
Can someone please kindly help me?

OSMC Log: https://paste.osmc.tv/sobinijuke

Thanks bye.

Did you try pairing them via the command line? This sometimes works better.

1 Like

No.
could you help me by writing me the commands please
Thanks

Hi,

The commands are here.

Thanks Tom.

1 Like

i tied to paring via command line
and pair, trust and connect worked correctly
but if i turn off headphones and the turn on
nothing is heard as long as I do not return to audio settings and carry over ASLA-> HDMI-> ASLA.

alternatively I have to wait 4/5 minutes without doing anything and then start to work

Thanks.

[AUKEY EP-B40]# info
Device 00:23:01:0A:14:5C
Name: AUKEY EP-B40
Alias: AUKEY EP-B40
Class: 0x240404
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Headset (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: Advanced Audio Distribu… (0000110d-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree (0000111e-0000-1000-8000-00805f9b34fb)
RSSI: -60

Are you now on the latest version? As you wrote you went back to October version?

yes because october version bluetooth headphones worked

Update to latest version, since May 2018 this is solved once and for all

ok after update
do I have to launch those commands?

sudo apt-get update
sudo apt-get install a2dp-app-osmc

It still should be installed but also would not harm to run again

the situation has drastically worsened after update. the problem described above persists and also now the quality of the audio is very bad (ALSA:Playback/recording through the PulseAudio sound server).

OSMC Log: https://paste.osmc.tv/raqoroxexe

first to make a clean installation from zero, do you confirm that it is normal that the sound of video is so badly than before? it seems that the actors speak from the bathroom …with the october ALSA version the audio is good like original sound, now with ALSA June version the video sound is awful
Thanks

I’m using A2DP streaming regularly on a Vero 4K.
I cannot reproduce this issue.

Can others?

it may be that now the bad works CSL bluetooth 4.0 stick nano ? it works since January 2016. I think no…

I decided I did a clean installation. i install osmc june

the first thing I did is check the bluethoot
but now i can’t connecting bluetooth headphones Aukey EP-B40 via command
error “Failed to connect: org.bluez.Error.Failed”. Paired is ok

in System setting/audio/audio input device i read
PI:HDMI

ALSA: Default(bcm2835 ALSA bcm2835 ALSA)

thanks

[bluetooth]# scan on
Discovery started
[CHG] Controller 00:1A:7D:DA:71:15 Discovering: yes
[NEW] Device 00:23:01:0A:14:5C AUKEY EP-B40
[CHG] Device 00:23:01:0A:14:5C RSSI: -79
[CHG] Device 00:23:01:0A:14:5C RSSI: -93
[bluetooth]# pair 00:23:01:0A:14:5C
Attempting to pair with 00:23:01:0A:14:5C
[CHG] Device 00:23:01:0A:14:5C Connected: yes
[CHG] Device 00:23:01:0A:14:5C UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 00:23:01:0A:14:5C UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 00:23:01:0A:14:5C UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 00:23:01:0A:14:5C UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:23:01:0A:14:5C UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:23:01:0A:14:5C ServicesResolved: yes
[CHG] Device 00:23:01:0A:14:5C Paired: yes
Pairing successful
[CHG] Device 00:23:01:0A:14:5C ServicesResolved: no
[CHG] Device 00:23:01:0A:14:5C Connected: no
[bluetooth]# trust 00:23:01:0A:14:5C
[CHG] Device 00:23:01:0A:14:5C Trusted: yes
Changing 00:23:01:0A:14:5C trust succeeded
[bluetooth]# connect 00:23:01:0A:14:5C
Attempting to connect to 00:23:01:0A:14:5C
Failed to connect: org.bluez.Error.Failed

Did you also install a2dp?

No…

I understood from your answer that they were already installed in osmc…

please could you confirm me the command to install?

sudo apt-get update
sudo apt-get install a2dp-app-osmc

Tanks a lot

I was referring to your previous install, where you obviously had installed it already.

A2DP is not installed by default but can now be installed without the need for development repository. So yes the commands to install are:

sudo apt-get update
sudo apt-get install a2dp-app-osmc

1 Like

ok headphones paired and connected
but the initial 2 problem with audio persist

  • the quality is badly. it seems that the actors speak from the bathroom …
  • when i switch off headphones i have to go in setting System / audio output device
    and carry over ASLA-> HDMI-> ASLA…

Have i set something in setting/System/Audio?

because I can not solve this problem even with a setup from zero…?

Thanks

Good!

Only for playback via the headphones?

This is strange, for me it works automatically if Bluetooth speaker disconnect audio went to HDMI if I connect them Audio goes to Bluetooth.

Suggest you enable debug logging and provide debug logs from the new setup.

1 Like