Problem with external USB drive samba sharing

Hi all. I have an ATV1 with crystalbuntu installed. I’m not very familiar with linux. Using the terminal app on my mac, I successfully edited the smb.conf file to share my drive using the following lines:
workgroup = CH
usershare allow guests = yes
security = share
follow symlinks = yes
wide links = yes
unix extensions = no
lock directory = /var/cache/samba
path = /media/NHD2TBHFSP1
available = yes
read only = no
browsable = yes
public = yes
writable = yes
guest ok = yes
force user = atv

My drive shows up on the network. However, I only have read access. I’ve attempted to write to the drive using a mac running El Capitan as well as with a PC running windows 10 but have been unsuccessful using both platforms. Any help with this issue would be greatly appreciated.

I’m a bit of a noob, but I would maybe try ssh in to device with terminal and type

sudo chmod 777 /media/NHD2TBHFSP1

note I am a raspberry pi user but the linux command should still work I think.
I am sure there are probably reasons not to grant permissions to everyone like this so maybe wait to see some other advice?? Or give it a try… up to you :smile:

also, off topic (sorry mods), but how is windows 10? easy to use?

I’m having kind of the same problem, I wrote about it in this thread: thread.

For me it looks like osmc isn’t setting up the correct group and guest permissions for the external drive.

When I try to chmod the drive, it fails with a weird error message I forgot.

I’m currently formatting my drive from exFat to ext4 to see if that is the reason the permissions aren’t set correctly. (You read a lot of self-contradictory stuff if you google long enough…). Time will show if the permission errors still appear - I’ll report back then.

what was the weird error?

Tried that, here’s what was returned:
chmod: changing permissions of ’ /media/NHD2TBHFSP1 ’ : Read-only file system
I also used chmod to change the permissions of a folder on the drive…still no luck.

BTW, I’m using a 4TB drive with two 2GB HFS+ partitions. I found that the ATV1 would not recognize a 4TB drive.

I think the problem I ran into with EXFAT and FAT32 was they don’t support files >4GB. I’ll try formatting the drive without journalling and report back.

I haven’t used it all that much (more of a mac guy myself). I put it on my wife’s computer and the little that I’ve used it, it’s a huge improvement from windows 8. The fact that it’s a free upgrade makes it even better.

Thanks all, I think I got it working using a bit of everybody’s advice! I decided to format the drive using Ext4 and now I am able to copy files.