Problem with iPlayer WWW and OSMC 2017.4.1

Hi, I am a newcomer to OSMC. I would like to stream BBC radio stations. I live in the UK.

I installed OSMC 2017.4.1 on a Raspberry Pi 3.
I added the iPlayer WWW add-on.
I eventually found and enabled the InputStream.adaptive (why doesn’t the add-on installer configure this dependency?)
When I use the OSMC UI on the console and select Music | Music add-ons | iPlayer | Listen Live | Radio 2 i get a couple of “Cookie load failed” messages followed by “One or more items failed to play Check the log…”

However, if I use the Chorus web interface via a browser and select Browser | Music | iPlayer WWW | Listen Live | Radio 2 it plays just fine!

logs (.kodi/temp/kodi.log): I have tweaked some of the URLs to enable posting

<log removed, please see update below>

That log isn’t really readable in the way you pasted it and it’s not a debug log. Please see the Wiki

debug enabled, system restarted, same error when selecting radio 2, log uploaded to here:
Contents of that link are too large to post here.

Hi, if iPlayer WWW doesn’t work, is there an alternative way to play BBC radio live stream in OSMC?

I, too, have been experiencing problems with iPlayerWWW.
With the 2017.3.1 release of OSMC it started working when I enabled the inputstream adaptive, and then stopped again the following day.
I updated to 2017.4.1 - still not working.
looked at this posting and changed from DASH to HLS - once again working for live radio and catchup (BBC).

Thanks Derek,
switching the iPlayer from DASH to HLS certainly seems to help … Radio 2 livestream worked, but when I switched to radio 4 OSMC crashed !

Really struggling to find any of these settings on my RasPi 2. Where should I be looking?

iPlayerWWW Settings, under the Stream tab.
How you get there may depend on which skin you use.