Problem with IR remote : solved by detector change

I have a system on a RPi1B with an IR diode attached to the GPIO bus to detect a device labelled as ‘PC Remote’.
It was configured as a 2018-10.1 OSMC with KODI 17.6, which was then updated to 2019-5.2 with KODI 18.3
In both instances the IR seemed to stop working after a while - timing unpredictable.
I’ve checked the remote is OK by using it on another OSMC system (much earlier config) with an IR receiver interfacing on USB, and it isn’t a battery problem.
I have some debug logs -
I may have this wrong, as I scrawled the url on a creased piece of paper which I found hard to read - I could send again if I knew what the commands were, as I wrote a copy to SD card.

You may need to record a new profile using irrecord.

Thanks for the advice. Unfortunately I have an inconsistency which I suspect is hardware base (SD card or connectors) so the irrecord and mode2 commands do not always work consistently (sometimes mode2 give non-stop O/P

I’m happy to report that problems seem to be due to contact problems, solved by changing the IR detector hadware.