Problem with Mediathek Apps

Hi there,
I have a problem to use the mediathek apps for ARD and ZDF, also to use tv guide apps. I cannot view content of the named mediatheks and no content of tv guide apps. Don’t know why, but the arte+7 app works fine.
In general, internet/network works fine with the Vero2.
My internet provider is unitymedia and I use the cable fritzbox from unitymedia.
I use a LAN cable and not WLan.
I started Vero2 out of the box, made updates, nothing special more - and I am a linux newbie.
It would be great, if you could help me here.

Best wishes
Norbert

This is a problem that might best be adressed at the developer of the plugin.

OSMC is only the OS Kodi is running on.

Thank you, mcobit, but I don’t think it is a problem of an app, because 4 different apps don’t provide me with data:
The both tv guide apps don’t send the tv program to the Vero and the both mediathek apps (ARD and ZDF, Germany) are not able to stream the tv content.
So I assume, that some basic settings are missing …

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

OK, I will send you the kodi log via OSMC, is that sufficient?
Please look at the log from 17:25 on. I started the vero2 and I tried first ‘ARD Mediathek’, then ‘ZDF Mediathek’, but I got no data back from both apps. With the kodi log viewer I saw, that I got write errors, but I can’t analyze the log.

http://paste.osmc.io/ekizohuziw

Please re-read the how to submit a useful support request again. What you have provided are not debug enabled logs. It would also be helpful to see the rest of your system logs.

yes, sorry missed that. Here are all logs with debug enabled before … same procedure: I started both ‘mediatheks’ but I got no data back … I hope, all required information is logged now.

Many thanks in advance!

http://paste.osmc.io/sawuqehipe

18:03:17 T:2578568176   DEBUG: get: http://www.ardmediathek.de/tv/Meistabgerufene-Videos/mehr?documentId=21282514&m23644322=quelle.tv&rss=true
18:03:17 T:2578568176   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IndexError'>
                                            Error Contents: list index out of range
                                            Traceback (most recent call last):
                                              File "/home/osmc/.kodi/addons/plugin.video.ardmediathek_de/default.py", line 615, in <module>
                                                listVideosRss(url,showName,hideShowName,nextPage,einsLike)
                                              File "/home/osmc/.kodi/addons/plugin.video.ardmediathek_de/default.py", line 136, in listVideosRss
                                                c = rssParser(content)
                                              File "/home/osmc/.kodi/addons/plugin.video.ardmediathek_de/default.py", line 190, in rssParser
                                                runtime = runtimeToInt(part)
                                              File "/home/osmc/.kodi/addons/plugin.video.ardmediathek_de/default.py", line 197, in runtimeToInt
                                                return int(HHMM[0])*60 + int(HHMM[1])
                                            IndexError: list index out of range
                                            -->End of Python script error report<--

ARD Mediathek has an issue. Address it with the addon developer http://forum.kodi.tv/showthread.php?tid=220852

http://forum.kodi.tv/showthread.php?tid=132563&pid=2449558#pid2449558

This appears to indicate that they are both broken and suggests where you should report your issues.

These problems are not related to OSMC. Good luck.

Many thanks for your support.
I just switched my provider from unitymedia to telekom and telekom supports the ‘mediatheks’ very well with their receiver, so the problem is solved for me.
For all other media I love the vero2 and osmc very much!

All the best to you for 2017!