Problem with OpenVPN set up on Vero 4K

#1

I have recently joined up to this forum after struggling to set up OpenVPN on my Vero 4k box.

I have been trawling through numerous forum posts and tutorials over the last few days, including the Brian Hornsby guide, but cannot seem to get my Vero box set up correctly to connect to my VPN, I am using Private Internet Access.

When I run OpenVPN, after selecting a connection it just constantly says “RECONNECTING” and system Info shows my usual IP address.

I am not too technically minded, and was unfamiliar with using programs like Putty and Filezilla beforehand. I believe I have followed the Brian Hornsby guide correctly, but I obviously must be doing something wrong, and would be extremely grateful for any help.

error(s) I get during test using Putty

My .ovpn file

OpenVPN settings - /usr/sbin/openvpn, Management IP 127.0.0.1, Port 1337
In “script”, I have “Use sudo when running OpenVPM” checked and “password” unchecked

0 Likes

#2

Fortunately, you seem to have got past the learning curve.
It looks like there might be some certificate errors there. Do the files vpn-config/crl.pem and vpn-config/ca.crt exist?

I’d recommend reuploading these files.

0 Likes

#3

Thanks for the extremely fast response.

Here is a screenshot of vpn-config folder and contents. ca.crt & crl.pem are there along with pass.text which I added.

I will try re-uploading the files like you suggest.

0 Likes

#4

Let me know how that goes. I’m not familiar with PIA but I know a few other users have this running; so they may be able to chime in and help you better than I can

Sam

0 Likes

#5

I have re-uploaded the ca.crt & crl.pem files.
I did notice straight away that the .pem file size is different from the original file downloaded onto my laptop so maybe there was an error when copying this file to my Vero box.

When I now select a connection in OpenVPN it does say “CONNECTED” but only for a minute or two.

When I go into System info & Network on the Vero box it still displays my usual IP address. The bottom line “Internet” displays alternating messages “Busy” and “Not connected - Check network settings”. This then reverts back to “connected” when OpenVPN stops trying to connect.

There’s obviously something else that is not quite right with how I’ve set this up but at least I feel I am getting somewhere now. Any further help would be greatly appreciated.

0 Likes

#6

I would recommend the zomboided kodi addon, takes care of all the config for you and works with most vpn providers. PIA is listed as supported.

0 Likes

#7

You’ll need to provide the OpenVPN log file. I believe Bryan Hornsby’s add-on writes its log to a separate file (rather than to the system journal). I might be wrong about the log file’s location, so please run the following command:

paste-log /home/osmc/.kodi/userdata/addon_data/script.openvpn/openvpn.log

or use the correct log file location, if that’s incorrect.

0 Likes

#8

Thanks for this. I have installed the add-on and it seems to work ok. The add-on status setting shows that I am connected to VPN and it displays external IP address.
The only thing that slightly concerns me is my service providers IP address is still displayed in Kodi System Information. I have read somewhere else that others had the same issue. Is this normal?

0 Likes

#9

Zomboided will give you your ip on screen, or you can check it over ssh. I guess kodi system info doesn’t refresh after each change.
If you ssh into your vero you can run

curl http://ipinfo.io

to get your current external ip

0 Likes

#10

Yes, it seems to be working ok.

Many thanks for your help, I felt like I was going around in circles trying to find an answer and I was able to do this in 10 minutes.

Thanks to everyone else who took the time to reply.

0 Likes

#11

Where can I find zombioded? I tried program, services and video add ons. None of them have zomboided. Or do I need to add a 3rd party repository?

0 Likes

#12
1 Like

#13

Thanks!

1 Like