Problem with OSMC Settings App after September Update

After updating to September release today i’ve seen 2 times same kind of problem. Both times manual update didn’t work (error msg) and i also now when seeing it 2nd time i tried other settings like Networking (but got error msg when trying to exit). In the end i could not exit the Networking section at all.

First time i got the problem reboot helped. (UPDATE) Now even after several reboots doesnt fix the error msg on My OSMC Networking section…

I have never had before any similar problems with previous releases since Alphas.

See full logs below

Also I don’t know if it’s just on mine, but the Network section in My OSMC is bugged, it opens with all the words jumbled up until you move the cursor with the remote. Also exiting doesn’t work, the only way out is to SSH and reboot.

I think I have a fix for that.

You can download it directly by going to the Updates module in MyOSMC, then down to Manual Controls, selecting Apply HotFix, and entering this code: [deprecated]

This will download the fixed file from github. You will need to restart for the new file to be read by the system though.

See above.

Let me know if the fix works.

Hi, i tried HotFix (output: rebooted and now My OSMC Networking section seems to work without problems. I was seeing the same ‘Jumble’ as Foxy_Stoat descbribed but now its gone.

Full Logs

Maybe its coincidence but after HotFix and reboot OpenWeatherMap Extended doesnt work anymore… Most likely i have to report it to Ronie at Kodi Forums.

Btw is it normal grab-logs -A gives permission denied as output ?

osmc@osmc:~/.kodi/temp$ grab-logs -A
sh: 1: /proc/cmdline: Permission denied
Logs successfully uploaded.

Good to know that the Networking section is fixed.

Nothing in that would have affected the WeatherMap

Also, grab-logs -A should be run with sudo to be able to get the cmdline entry.

Your logs identified a different issue with the updates module. It might not indicate when an update is available, so you might want to check manually every few weeks.

This is the HotFix code to fix the Updates issue: oyeyeweluz

Is this latest HotFix included in todays OSMC update ?

Start-Date: 2015-09-29 21:34:12
Commandline: apt-get -o APT::Status-Fd=4 -o APT::Keep-Fds::=5 -o APT::Keep-Fds::=6 -f -y dist-upgrade
Upgrade: mediacenter-addon-osmc:armhf (3.0.491, 3.0.494), base-files-osmc:armhf (1.5.9, 1.6.0)
End-Date: 2015-09-29 21:34:32


Ok, thanks for the team for very quick responses and fix!

I can’t exit from Network settings in “My OSMC”. Nothing happening on “Exit” entry or Back button pressing.