Problem with PI2 and Hyperion


i know there are multiple threads about this, but i can’t find a solution in it.
So, my hyperion won’t work with OSMC and my PI 2 (with my old PI B and OSMC it works fine)
dtparam=spi=on is in my config.txt and the /dev/spidev0.0 exists.
i tried with a clean installtion, nothing changed
i tried hyperion with the startup as root and as osmc user
everthing i read is about a spi bcm2708 module, but where can i get it? it looks like my system is missing it.

hier some information

lsmod | grep spi
spi_bcm2835 8471 0

find / -name “bcm2708” 2>/dev/null
/sys/bus/platform/drivers/bcm2708_fb /sys/devices/virtual/bcm2708_vcio /sys/class/bcm2708_vcio /sys/module/bcm2708_fb /lib/modules/4.4.1-1-osmc/kernel/drivers/i2c/busses/i2c-bcm2708.ko /lib/modules/4.4.0-1-osmc/kernel/drivers/i2c/busses/i2c-bcm2708.ko /proc/irq/46/bcm2708_fb dma

ll /lib/modules/4.4.*/kernel/drivers/spi
/lib/modules/4.4.0-1-osmc/kernel/drivers/spi: total 20 -rw-r--r-- 1 root root 16732 Jan 12 20:13 spi-bcm2835.ko /lib/modules/4.4.1-1-osmc/kernel/drivers/spi: total 20 -rw-r--r-- 1 root root 16732 Feb 15 03:18 spi-bcm2835.ko

i hope someone can help me.

king regards Bootscreen

What leds are you using? i have my self lightpack(usb) and lpd8806(GPIO) and both work fine…


I am using LPD8806 on the GPIO Pins. With my PI B and OSMC, hyperion and the same hyperion.config.json it works fine too. only with the PI2 it doesn’t work

Wierd my lighpack works just fine and im using GPIO (Lightberry)

so, its not a problem that i don’t have a spi-bcm2708.ko ?

could it be a problem that i have wiringpi installed and use gpio 02, 03 and 04 for a relay switch
could it be a problem that the LED Stripe gets its power after boot?

shouldnt need that file since all you need is dtparam=spi=on in config.txt

hmmm… than it looks like my PI2 is broken :unamused:

does anyone knows whether i can use my old PI B with hyperion and my PI 2 with OSMC ?

doesnt necessarily mean that its broken alot of users has experienced issues with hyperion lately could be bugs in the software if you look in the forum you will find alot of threads regarding hyperion.

could do a last ditch effort and go to the hyperion github tracker and report your issue.

the easiest way to find out is just to disable your replay switch and remove the pins from GPIO and then try your lpd8806 again.

maybe do a clean install and only setup hyperion.


damn -.- my card reader blowes up. so i can’t test a new installation.

but i noticed an other thing
on my PI2 the gpio readall gives an other result than on my PI B: the SCLK was 1 not 0

PI 2

gpio readall
| BCM | wPi | Name | Mode | V | Physical | 10 | 12 | MOSI | ALT0 | 1 | 19 | 9 | 13 | MISO | ALT0 | 0 | 21 | 11 | 14 | SCLK | ALT0 | 1 | 23


gpio readall
| BCM | wPi | Name | Mode | V | Physical | 10 | 12 | MOSI | ALT0 | 1 | 19 | 9 | 13 | MISO | ALT0 | 0 | 21 | 11 | 14 | SCLK | ALT0 | 0 | 23