Problem with projector and spontanous black screens after using Kodi 19.1

Hi everyone :slightly_smiling_face:

I am using the latest osmc with Kodi 18 and everything is running fine on that RPi3b. So now that Kodi 19.1 is out, I set up a second RPi3b in prallel to my current running one and installed OSMC from scratch. All plugins and stuff is working, but I am facing weired connection losses/black screens while watching movies. It doesnt matter if I watch Netflix, Amazon, normal movies or series or Youtube. It happens the same in all sources. Only in the OSMC UI there are no black screens. The movies just start playing normal, but then the screen (projector EPSON EH TW 9200W) gets black for a couple of seconds, while the audio is playing normal. No flickering signs on the AVR (Yamaha RX-V475) the Pi and Projector are connected to. Then the movie image returns normal just to disappear again after a minute or so. And so on and so on … No special time order.

I dont experience this kind of issue on my second Pi running latest OSMC with Kodi 18. Everything is normal there.

So what I tried already is the following:

  • I put the SD card with Kodi 19 into the other Pi running Kodi 18 → same problem
  • I switched the PSU to a 3A → same problem
  • I replaced the HDMI cables between Pi and AVR and between AVR and Projector → same problem
  • I copied the edid.dat and /boot/config.txt settings from old Pi over to the new Pi


→ still same problem

  • I set hdmi_mode=16 in addition in /boot/config.txt → same problem
  • I tested with just WIFI and just LAN connected → same problem
  • I switched dtoverlay=vc4-kms-v3d,cma-512 in /boot/config.txt to dtoverlay=vc4-fkms-v3d,cma-512 → video starts, but gets laggy immediately
  • I directly connected the Pi to the Projector → works
  • I attached a HDMI splitter between Pi and AVR/projector (same like directly attaching Pi to projector) → works, unfortunately, it doesnt support CEC, what I am using :confused:

Ok … if I directly connect the new Pi to the projector, I dont have those black screens during video playback. And I also dont have them on the old Kodi 18, what brings me to the conclusion that it might be something software related rather than a hardware issue as it only pops up with new OSMC with Kodi 19. During video playback I ran a “tail -f /home/osmc/.kodi/tmp/kodi.log” to check if during the black screens something gets logged. But even with debug logging enabled the log is quiet.

What I also noticed is that tvservice doesnt work like on the old osmc:

osmc@jodoosmc:~$ tvservice -n
[E] No device present
osmc@jodoosmc:~$ tvservice -m CEA
Group CEA has 0 modes:
osmc@jodoosmc:~$ tvservice -l
0 attached device(s), display ID’s are :

If I issue this command on the old RPi, it answers correctly. During I set the vc4-fkms-v3d setting, tvservice answer correctly on the new Pi, but playback and cec doesnt work.

Currently I dont have further idead where or what to tune, to get this fixed. So currently I switched back to the other installation with Kodi 18 and all is fine :frowning: I really would like to move on with Kodi 19, as everything else is already migrated and set up, “only” the movie playback is left :smiley:

I generated a log here (yet it is no debug log as nothing of the problem was logged while debug logging was active, but I can provide one if neccessary):

Thanks for the comprehensive report.

It doesn’t work with KMS. We’re looking for new tools to populate the logs. Meanwhile, can you post the EDID for your projector and for the projector through the AVR.

sudo apt-get update
sudo apt-get install edid-decode
edid-decode /sys/class/drm/card0/card0-HDMI-A-1/edid

change connections and re-boot

edid-decode /sys/class/drm/card0/card0-HDMI-A-1/edid

Hi, thx for having a look, here are the outputs:
first one is with AVR and second one is directly with projector.

Anyone got some news on this?
A colleague had a spare HDMI 4k splitter wuth CEC support. I am currently using it in between and it works, problem also solved.
But would be nice not to need extra tools and cables :frowning:

I’ve noticed the same problem. Not as bad as with you, just once or twice while watching a movie.
I also have intermittent problems with no audio at all. Disabled passthrough for now until I find a solution.

BenQ W2000 connected to Onkyo NR656.

Hm seems to pop only for users with projectors :slight_smile:

i also have this issue. Epson 5030 projector on Vero 4k+ running 19.1. Only happened twice but it was during an extended use of the projector and haven’t used it for that long since.

Just updated my receicer Yamaha RX-V473 to fw 1.23 and my Epson EH-TW9200W to fw v112. Unfortunately, didnt help :slight_smile:

Still a HDMI splitter is tje only (unneccessary) workaround :frowning:

Just switched over to a RPi4 and this problem doesnt show up on RPi4 with same OSMC and kodi installation.
Still persistent on RPi3.

i do have the same issue on Vero 4k directly connected to samsung TV since i moved to 19.1