Problem with UHD Playback

Yesterday i´ve buyed a Panasonic TX-65EXW784 UHD TV and now i´ll try to see a UHD Movie, Oblivion. The result is very very poor… heavy stutterings at the begin and in the movie and the message that the source is too slow for playback, massive sound dropouts, so the movie isn´t playable - no problem with my Full HD Movies and also the same Movie in Full HD.My equipment:

Untouched mkv, the source is my Synology NAS, connected via SMB, use Emby Server as media server.

The Logs:



You’ve seem to have setup you video mount via fstab, but are still using kodi smb shares:

I would try changing to the video source to /mnt/video. When browsing the video source, select root file system then mnt, and then video. You should get better throughput then.

If not you could switch to using nfs from the synology.

Thanks Tom.

I´ll do a test with /mnt/video but this didn´t solve the problem - same stutterings at the begin and the message that the source is too slow for playback… :frowning:


You could try nfs then, overview of the server side setup:

Client side:

Nfs gives better throughput that smb

Thanks Tom.

Ok, do another test with nfs and have no stutterings at the beginning… i´ll do more tests tomorrow to proof this… thanks for help, will report the result then!

Try USB playback first to verify playback is OK. Then we can move on from there.

It seems that mount the shares via NFS solved the problem… test the first 30 minutes of Oblivian without stuttering. Now i´m searching for a way to configure the fstab mount in the Emby Server for the best performance…

Just for information… configured nfs via fstab and use this as source in my Emby Server - works fine, tested with some UHD movies and no stutterings occured! :slight_smile:

I wonder that the configuration of nfs via fstab is so much faster than smb or the kodi nfs…

1 Like

Unfortunately the problem isn´t solved! I configured nfs via fstab, playing some 4k movies without stutterings but now i watch “Serenity” and the movie stops many times to buffer and has heavy stutterings!

The logs:


Unique ID : 208273395321812007131259172610037482859 (0x9CAFFF32AC1B5835188B3BA9AF57856B)
Complete name : V:--=Filme=–\Serenity - Flucht in neue Welten (2005) tt0379786 uhd bluray\Serenity - Flucht in neue Welten (2005) tt0379786 uhd bluray.mkv
Format : Matroska
Format version : Version 2
File size : 48.2 GiB
Duration : 1 h 58 min
Overall bit rate : 58.0 Mb/s
Movie name : Serenity
Encoded date : UTC 2018-01-24 11:55:55
Writing application : MakeMKV v1.10.10 win(x64-release)
Writing library : libmakemkv v1.10.10 (1.3.5/1.4.7) win(x64-release)

ID : 1
ID in the original source medium : 4113 (0x1011)
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
Duration : 1 h 58 min
Bit rate : 54.0 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.271
Stream size : 44.8 GiB (93%)
Writing library : ATEME Titan File 3.7.9 (
Language : English
Default : No
Forced : No
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Original source medium : Blu-ray
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0050 cd/m2, max: 1000 cd/m2
Maximum Content Light Level : 996 cd/m2
Maximum Frame-Average Light Level : 263 cd/m2

ID : 2
ID in the original source medium : 4353 (0x1101)
Format : DTS
Format/Info : Digital Theater Systems
Format profile : X / MA / Core
Codec ID : A_DTS
Duration : 1 h 58 min
Bit rate mode : Variable / Variable / Constant
Bit rate : 3 931 kb/s / 3 931 kb/s / 1 509 kb/s
Channel(s) : Object Based / 8 channels / 6 channels
Channel positions : Object Based / Front: L C R, Side: L R, Back: L R, LFE / Front: L C R, Side: L R, LFE
Sampling rate : / 48.0 kHz / 48.0 kHz
Frame rate : 93.750 FPS (512 SPF)
Bit depth : / 24 bits / 24 bits
Compression mode : / Lossless / Lossy
Stream size : 3.27 GiB (7%)
Title : Surround 7.1
Language : German
Default : Yes
Forced : No
Original source medium : Blu-ray

I do a test with my other mediaplayer that i need for 3D ISO playback, a Himedia Q5 Pro and have no stops to buffer or stutterings in the movie!
Any idea or solution? It seems that some 4k movies works and other not so the Vero isn´t useful for 4k at the moment for me… :frowning:


Hi Mike,

Have you tried play Serenity back locally?

Thanks Tom.

The Vero 4K has problems with some 4K files that other players dont have including Serenity and John Wick 2. They always hang for a while at the same place.

I’ve seen reports of JW2 and Serenity being affected. If there are other clips that are also problematic, please let me know.

We’re investigating this.

Cars 3. Kept losing sound every 10-15 minutes or so. I’ve seen this before in Disney titles. Possible related to branching.

Debug log of this might help. Did the picture itself break up?


I’ll try to get you one tomorrow.

I´ll hope you find a solution for this…

The audio dropouts may be to do with the bitrate of the atmos track - the Vero has problems with the POTC dead men tell no tales atmos track due to the bitrate and had several audio dropouts.

Have a look at this and give it a try: Playback improvements for 4K HEVC UHD content

Maybe it resolves the issue with Dean Men tell no Tales, too :wink: