Problem working a Media on Raspberry Pi 3 (Display 800x480 15:9 HDMI)

Hi All,
I have tried to make the OSMC to work on 7" Touch screen 800x480 15:9 and it did after some setting change. but now i can’t get the video (online or on the SD/USB) and the MP3 to work. it only partially work right after the startup then nothing work again.

what i have added was the below to the Pi Config

    hdmi_cvt=800 480 60 6 0 0 0 

there is Bluetooth A2DP add-on from OSMC work fine on the TV. also i have noticed but after a longer use that the same have happen on the normal TV with same setup/configration.

also i have noticed that the startup splash is not working with 800x480 but it could be 600x480 4:3

I thought it would be a buffer problem as the buffer word come up on the upper right and the streaming total stops while the time keeps on counting “ex. 1:30/0:20” (in case of youtube only) so i have tried advanced setting.xml with no change.

i start to believe that its related to the conversion from higher resolution to a lower one issue or something.

the logs in the following link: