Problems accessing nfs share on Raspi2

Hello everyone,

I hope anyone of you can help me to fix my NFS-issue since many hours of research and trial and error have not brought me even close to a solution. :unamused:

I have a QNAP NAS with NFS enabled and want to access my files on the shared NAS-Folder from my raspi. On my raspi2 I can not get this done while on my raspi1 it works fine. Both raspi run the same OSMC-version 17.1.
I tried to mount the NAS-Folder via /etc/fstab exactly like on the raspi1 (copied and pasted it), but can not access the NAS nfs shares in osmc. Neither via sources.xml (also copied and pasted) nor via the mounting home-folder. When I search for the NAS-folder in osmc while adding a new video source, the IP-Address of the NAS is shown in the list of nfs network shares. When clicking on it, all NAS folders are shown, but when I select one none of the content is displayed. Same result with autofs.

Showmount via ssh also show all NAS-folders, but the mounting destination on my raspi2 is empty.

Here is some information from my NAS NFS server:
/share/HDA_DATA/Multimedia ,,insecure,root_squash,all_squash,async,wdelay,no_subtree_check,uuid=xxxxxxxx:xxxxxxx:00000000:00000000)
/share/NFSv=4 *(ro,insecure,no_root_squash,sync,wdelay,no_subtree_check,fsid=0)

and here you can see my autofs-settings:
in /etc/auto.nfs: NAS_Multimedia -fstype=nfs,rw,retry=0
in /etc/auto.master: /home/osmc/nfs /etc/auto.nfs

Here you find the rasp2 kodi.log.

thank you all for your support! :smiley:

It’s a bit hard to read your post as you didn’t use the preformatted text button.
Anyhow it seems you are only exporting for and not second IP

I think @fzinken is right about the export on your NAS. But I also wonder why you are using the auto.nfs style of mounting? You may be better off using /etc/fstab for mounting on the Pi.

@fzinken: sorry for the text not being easy to read. Can I edit my post and change the format? Had just used copy and paste :wink: What do you mean exactly by “preformat” so I change it correctly?

Anyhow: thank you for the hint on the IP. very interesting that my qnap NAS uses my router IP in the nfs settings.

In the GUI of the NAS there was just a field to enable nfs, nfs version4 and chose the folders to be shared. I also was able to chose the squash option. The uid was set to “guest”.

I guess the router IP or settings of the NAS is not the cause for my problem since it is working fine on my raspi1.

@bmillham: I had tried with /etc/fstab first. The result was the same, so I thought I try out autofs to see if that works. Had no luck. :disappointed_relieved:

Would you like to see the /etc/fstab from my raspi1 which was copied to raspi2?
How do I deactivate the autofs service when I want to switch back to use only /etc/fstab ?

Thanks for your support! :slight_smile:

Yes you can edit your post there is a “pencil” button below your post.
When you edit your most mark any text that inclused parts that could be interpreted as format e.g. # <> and press above the editor the button called preofrmatted text which looks like </>

That would be strange and only be the case if your router does NAT which would explain why it doesn’t work.
Are your two Pi’s and the NAS on different subnets? What are the IP’s of the Pi’s?

Just for your info the structure of the exports file.
directory machine1(option11,option12) machine2(option21,option22)