Problems connecting to new WiFi on a previously working system

I have Raspberry Pi model B+ with a TPLink WiFi adaptor. I’ve been using this for internet connection for a couple of months previously and it’s been fine, but I’ve recently moved house, and have a new WiFi network on a different router.

All my other devices can connect to the new network fine, but the Pi can’t. (The router is pretty fresh out of the box and still on all its default settings, with WPA2-PSK security.) The correct network SSID is listed, I can select it and put the password in, but it always just says that the connection has failed. Nothing about the hardware itself has changed (though I’ve tried putting the adaptor in different USB ports of the hub and also directly in a USB port on the Pi) and I’ve not installed updates (because no connection). I’m also pretty sure I’m typing the password correctly - it’s alphanumeric, so no tricksy characters, and I’ve tried using both a hardware keyboard and the on-screen one.

I can connect via ethernet cable, so here are (hopefully useful) logs:

How can I fix this? I’m fairly inexperienced with Linux / OSMC and I just don’t know what else to try.

Wifi logs are always difficult to decipher, but these lines seem to suggest that OSMC is trying to connect to an open (unauthenticated) network:

Dec 11 21:29:29 osmc wpa_supplicant[222]: wlan0: Trying to associate with e8:37:7a:93:db:7c (SSID='ZyXEL_DB7C' freq=2417 MHz)
Dec 11 21:29:29 osmc kernel: wpa_set_auth_algs, AUTH_ALG_OPEN_SYSTEM
Dec 11 21:29:29 osmc kernel: set_mode = IW_MODE_INFRA
Dec 11 21:29:29 osmc kernel: 

As to why that might be happening (assuming you have entered the pass phrase correctly) not a clue…

Okay, thanks, that’s something to look into if I can work out how!

Meanwhile I found this thread: Could not connect to Wi-Fi - #19 by Marky
And went through the steps to try and connect manually using connmanctl, as recommended a few posts down. That got me connected to the network (on the third try but there was maybe some messing around with timing out while I found the password?), but then on starting up Kodi, the wireless network was showing as connected (with IP address, DNS gateway etc.) but with no internet. All the other devices connected to this network think they’ve got internet and the connection here is generally sound so something appeared to have gone astray there.

I captured the system journal, as requested in that other thread:

After a reboot, the wifi failed to connect from Kodi in the usual way, and then on returning to connmanctl, I also couldn’t connect manually, in the same way as in that other thread.

The conclusion of that other thread seemed to be ‘try another wifi dongle’, but this one has been known working, on this system, automatically on every boot (I didn’t even have a way to connect via cable in my last place) just on another wifi network. So why can’t it connect to this one?

Have you checked the configuration options in your wifi router ?

Try a google search for your new wifi routers model in relation to linux devices connecting to it. Maybe there is a known compatibility issue with Linux that can be worked around by changing one of the routers settings.