Problems creating lirc config file using irrecord

Hi there.

I am trying to use a TSOP1738 IR receiver together with a silvercrest SFB 10.1 C3 universal remote control to control Kodi on my Raspberry Pi 3B+. I know it is possible, since this setup has worked the last time I used OSMC, about 2 years ago (but I lost the lirc config file sadly).

What I have done so far:

  • Connected IR receiver to power, ground and GPIO25 pin.
  • Added dtoverlay=gpio-ir,gpio_pin=25 to the /boot/config-user.txt file through My OSMC.
  • Confirmed that the IR sensor is working by testing with the mode2 --driver default command. This porduces a lot of ‘space’/‘pulse’ output, which seems to indicate that the receiver is working.

To create a new config file for the remote, I am trying to use irrecord -d /dev/lirc0 --driver=default. The program prompts me to start pressing buttons on the remote control and fill two lines on the terminal with dots, but after one line the program seems to stop responding to IR pulses and provides the following output:

Press RETURN now to start recording.
Got gap (95388 us)}

Please keep on pressing buttons like described above.
..Cannot find any gap, using an arbitrary 50 ms one. If you have a
regular remote for e. g., a TV or such this is probably a point
where you hit control-C. However, technical hardware like air
condition gear often works without any gap. If you think it's
reasonable that your remote lacks gap you can proceed.
Press RETURN to continue.

It seems that irrecord is able to detect a gap of 95388 microseconds, and subsequently forgets that information. If I continue the process, the config file generated has a 0x00 value for each key.

I have no further experience with LIRC and have not been able to find an up-to-date tutorial for configuring a new remote with OSMC, so it could be that some of my assumptions are simply wrong.

I am not sure how to continue debugging this problem. Can someone give me some pointers in the right direction?

Sidenote: before using the mode2/irrecord commands I stop the lircd_helper@lirc0 and eventlircd services to keep them from interfering.

System info:

Hardware: Raspberry Pi 3B+ with the IQaudIO DAC Pro hat.

osmc@osmc:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 11 (bullseye)
Release:        11
Codename:       bullseye
osmc@osmc:~$ uname -a
Linux osmc 5.10.78-7-osmc #1 SMP PREEMPT Fri Sep 2 02:43:52 UTC 2022 armv7l GNU/Linux
osmc@osmc:~$ lircd -v
lircd 0.9.4c

Did you stop eventlircd and the LIRC helper before making a recording?

Your TSOP could also be subject to interference.

Yes, I stopped the eventlircd and lircd_helper@lirc0 services before making a recording.

The irrecord tool produces the following output:

Checking for ambient light  creating too much disturbances.
Please don't press any buttons, just wait a few seconds...

No significant noise (received 0 bytes)

which seems to indicate there is no interference.

I have also tried to install an older version of OSMC to create the remote config file, since I have been able to configure the remote with the same hardware in ~2019, but I have not been able to find such an old version of OSMC for the Pi 3.