Problems installing no-ip updater

Hi Everyone,

I’ve just installed OSMC, having used Raspbmc for a few years. I’m trying to install the no-ip updater software on my Raspberry Pi (I didn’t try this in Raspbmc) but I’m new to linux and i’m getting stuck. I’m new to this forum to but I’m hoping someone can help me out, I’m sure it’s a very basic thing I’m trying to do.

I’m following the instructions at the following link How to Install the Dynamic Update Client on Linux

I get to the command

sudo make

and get the following error.

/home/pi/noip/noip-2.1.9-1$ sudo make
sudo: make: command not found

I’ve read that this error can occur if GCC is not installed, so I tried the following;

sudo apt-get update
sudo apt-get install rbp-userland-dev-osmc (not sure if this was needed)
sudo apt-get install gcc

I’ve rebooted and I’m still getting the same error. If anyone can point me in the right direction it would be a great help.

Many thanks in advance,


1 Like

Try installing build-essential - that is usually all that is needed for compiling software on OSMC.

1 Like

Many thanks for the quick reply.

This resolved my issue. I spent a few hours last night wrestling with this so it’s a relief to be over that particular hurdle… onto the next one. Getting it to run at startup. I’ve done this before in the distance past so this shouldn’t be too much trouble.

Thanks again

I know the discusion is from 2015…but…i can’t make no-ip to install on my pizero…

obvioussly make does not work and i try sudo apt-get install build-essential, but i get :slight_smile:

Do you want to continue? [Y/n] y
Extracting templates from packages: 100%
Preconfiguring packages …
(Reading database … 26919 files and directories currently installed.)
Preparing to unpack …/libc6_2.28-110.4_armhf.deb …
Unpacking libc6:armhf (2.28-110.4) over (2.28-10+rpi1) …
dpkg: warning: old libc6:armhf package post-removal script subprocess was killed by signal (Segmentation fault)
dpkg: trying script from the new package instead …
dpkg: error processing archive /var/cache/apt/archives/libc6_2.28-110.4_armhf.deb (–unpack):
new libc6:armhf package post-removal script subprocess was killed by signal (Segmentation fault)
dpkg: error while cleaning up:
installed libc6:armhf package pre-installation script subprocess was killed by signal (Segmentation fault)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


I suggest creating a new post with logs:-

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Have you run sudo apt-get update recently?

Yes, i did.