Problems installing OSMC - freezing?

Hello all,

I’m trying to install OSMC on a PI-B with a 16GB SD card.
First attempt was using Noobs and installing OSMC. After extracting the files (still the Noobs screen) there was no reaction for some 15 minutes. A hard reboot failed.
So I tried the OSMC image (OSMC_TGT_rbp1_20150519.img) directly and put it on the SD card.
This time I have seen the OSMC startup screen and then it started to install. But before reaching 50% it did also freeze and I do not see any progress anymore.

Any idea what’s going wrong ?
Or am I just not paient enough ?

Likely an issue with your power supply


Thanks for the fast respone.

The device worked quite well for a long time before (using the same power supply).
The power supply is rated
But I was using Raspbian and now I wanted to the the media center.

That’s the reasonwhy I would exclude this fault reason.
Or is OSMC challenging the CPU that much ?

My devices on the PI at the moment: Just a keybord and a mouse (both wired).

Why not try booting the Pi with a new image on the card but nothing plugged into it? If it’s a power problem, that may free up a few mA.

Unfortunately that’s faulty reasoning.

The Pi is very sensitive to getting the correct voltage and many (most ?) USB chargers not specifically made for the Pi are not really up to the task. The power demands depend on how much overclock you use and the CPU/GPU use that the software demands, as well as the demands of any USB peripherals.

It is perfectly possible for a given power supply to boot one operating system (perhaps at the default 700Mhz clock speed) ok but freeze on another operating system like OSMC where the default clock speed is 875 Mhz.

These install images are well tested and hundreds of thousands of people have downloaded them and not had issues installing. If the installer can’t even complete installing you have a hardware problem, no question about it. The fact that another OS boots doesn’t rule out a hardware issue.

Most likely power related as Sam suggested, but it could also be a bad SD card. Please try a different SD card and/or power adaptor.

Thanks for your support.
I was offline and just went the way you described:

  • First changing the power supply. But no changes
  • Then I have taken away mouse and keypad to reduce power consumption. Here the system stopped even earlier (according to the progress bar)
  • The last action was to substitute the SD card. And here we go.

Now OSMC is up and running on my PI. I only need to understand all the features and possibilities of it.

Welcome to the club :slight_smile: