Problems playing UHD ISO via NAS

Hello,

i have a problem with playing UHD.ISO files.

At first I thought that they wouldn’t play at all, but that’s not the case.

If I have the UHD.ISO on a USB stick on the Vero 4K+ it will play without problems.

If I want to play the same UHD.ISO from my NAS, it simply won’t open.

The m2ts file on the ISO will be played on the NAS without any problems.

OSMC/Kodi seems to have a general problem here if I want to play a UHD.ISO on the network, because it is exactly the same with the Windows version.

Only if it is from the local memory like a USB storage you can…

Does anyone know why this is so?
It is the same filem…

PS: Sorry for my english… i use deepl

Hi, I got my Vero 4K+ yesterday.
After the setup I tried something and a few things make me sad.

I would like to play UHD movies as .iso.
On my Windows PC this works without problems, but unfortunately not on the Vero 4K+.
Is there a solution?

I also have a movie image as .mkv which is in resolution 3840x16xx.
On my Windows PC this is played without problems.
The Vero 4K+ makes image errors in the lower black area.

Is there a solution?

Many greetings

PS: Sorry for my English… i use deepl…

Translated with www.DeepL.com/Translator

Hi MEKak, I merged your double posts to this new topic.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Is the ISO encrypted?
The logs will help

Sam

Hi,

thank für your help.

Here is my Log:

https://paste.osmc.tv/ogefobaqej

i think the ISO is encrypted…

Did you rip the ISO yourself?

No, I didn’t…

I don’t think that’s the problem either, because the same ISO is played by a USB stick…

Many greetings

I see that you are using UPNP. Could you try configuring the NAS to use NFS and try accessing the ISO that way? UPNP is a FUSE (userspace) driver and will not give you the same performance as an NFS mount will.

Jes, i use UPNP.

i can try it.

This is a good idea.

I’ll write later on how it worked.

EDIT:
I have no idea how to configure NFS.
I did it in my Synology but OSMC doesn’t find any files in the folder …

Did you follow these instructions precisely?

https://kodi.wiki/view/NFS#Synology

Hi,

i have tried it all the time now and had a thinking error with the NFS setup…

It can’t work if you enter the wrong IP address :slight_smile:

Now I have access to the NAS via NFS and now the UHD.ISO are also played.

It was actually UPNP…

Many thanks for the quick help !!!

1 Like