Problems with 3D ISO Files

I got the new Vero V today and I’m pretty disappointed. There were already several crashes during setup, even the skins tried and tested on the Pi don’t work in some cases (>crash).

Above all, the 3D ISO files (playback from NAS) do not work correctly. SBS and HUD work perfectly, the framepacked files (MVC) are also recognized correctly, but are only played back on the 3D TV at about 3-4 fps (!) and are buffered again and again. When playing the same files via USB-Stick everything works fine-

Info: network connection via cable, normal 4K video files, on the other hand, work perfectly.

I couldn’t find anything in the Wiki, please help me urgently, otherwise I’ll have to send the device back.

Best regards, Ernst

It’ll be easier for the OSMC guys to help you if you post some debug-enabled logs. See here, under “Providing diagnostic logs”.

1 Like

This doesn’t sound right at all. We will need to see some logs to get this solved promptly.

Rest assured - Vero V fully supports 3D MVC playback and we will be able to get this working.

But it is Christmas here so it may take a few days to get this solved

We remain committed to supporting 3D playback on Vero for the foreseeable future

Thanks for your understanding


I would suggest checking that you are running the same version of Kodi on both Pi and Vero. Some skins simply haven’t been updated or maintained over the years as new versions of Kodi have been introduced.

Hi Sam,
thanks for the quick answers. There are two phenomena when playing 3D MVC files: Some movies buffer every few seconds (see log For other movies, the video is played back continuously, but at an estimated frame rate of about 5 frames per second (see log
In the second log file, I started a 4K movie after playing the 3D video, which was played back flawlessly.
In no case does the Bluray menu work (which my relatively old Dune player can do perfectly).
Best regards from Austria, Ernst

Translated with DeepL Translate: The world's most accurate translator

Thanks for the info! I have posted the corresponding logs.
Best regards, Ernst

Dear team, I am sorry about your efforts - the problem was not with the Vero, but with a defective Ethernet cable. The 3D MVC files are now playing perfectly.
What is not working are the Bluray menus and the IR remote control.
Thanks for the quick support, though.

Have you installed the Java Package from OSMC Store that is needed for Blueray menus?

Noop, I didn’t know about it. I’ll Try, thank you

I didn’t find any addon called bluray or java or menu :see_no_evil:

It’s under My OSMC → App Store.