Problems with DVD-Playback

I don’t really know if this is the right place to post this, but I hope so.
I have some issues with the dvd playback.

  1. The automatic playback doesn’t work. When i put a dvd in the tray it just ask me if I want to search for images, videos or music, but doesn’t start the playback. I have to start the dvd manually.
  2. EjectTray() also doesn’t work. It just says DISC_NAME* successfully removed. But it doesn’t open the tray, it just removes it from the device list.

I use the Raspberry Pi Original B Model and OSMC RC.

*Name of the Disc, e.g. PERSON_OF_INTEREST_SEASON_3

Assuming this is an encrypted disc?


I think so, yes.
But on a test system using OpenELEC, everything worked.

Seems we may need to add libdvdcss.

So at this moment I can’t change it?

No, I’m not even completely sure this is the issue. A log would help here.

No problem:

Hi Sam,

I have the same problem and all the DVDs I’ve tried surely are encrypted.


I encountered also the DVD play back issue with some commercial DVDs. I can
rule out hardware issues as the DVDs can be blacked using the same DVD
device on my Ubuntu laptop.

In dmesg, I see the IO error normal to copy protected DVDs. Before I
updated OSMC, I saw the “Add. Sense: Read of scrambled sector without
authentication” error message. After updating to KODI 16 beta, it turned
to the following error. But I think this is essentially the same:

[51173.396220] sr 0:0:0:0: [sr0] UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[51173.396252] sr 0:0:0:0: [sr0] Sense Key : 0x5 [current]
[51173.396267] sr 0:0:0:0: [sr0] ASC=0x6f ASCQ=0x3
[51173.396287] sr 0:0:0:0: [sr0] CDB: opcode=0x28 28 00 00 00 04 00 00 00 02 00 00 00
[51173.396305] blk_update_request: I/O error, dev sr0, sector 4096
[51173.396321] Buffer I/O error on dev sr0, logical block 512, async page read

KODI produces the following output:

11:54:06 51396.773438 T:1867576304 INFO: Detecting DVD-ROM media filesystem…
11:54:06 51396.800781 T:1867576304 INFO: CD Analysis Report
11:54:06 51396.800781 T:1867576304 INFO: __________________________________
11:54:06 51397.023438 T:1867576304 INFO: CD-ROM with ISO 9660 filesystem
11:54:06 51397.023438 T:1867576304 INFO: ISO 9660: 1151849 blocks, label
11:54:06 51397.023438 T:1867576304 INFO: Tracks overall:1; Audio tracks:0; Data tracks:1
11:54:06 51397.125000 T:1867576304 INFO: Using protocol iso9660://
11:54:06 51397.125000 T:1867576304 INFO: Disc label:

Also the “Play Disc” button comes up. But Kodi is not able to start
the playback. As said, I’m able to watch the disk using vlc on my
laptop. Any hint is welcome …

Best regards,

It’s kind of irrelevant whether you can play the disk on another device or not - a read error is a read error. If a read error reading the disk occurs Kodi will not be able to play the disk correctly. A physical read error is a hardware issue - we can’t fix that in software.

Are you trying to power the DVD drive from the Pi ?

I think I was not clear in my initial reply. I played the same DVD with one and the same DVD drive on another laptop for verification. I can also play other DVDs with my Pi and I have this issue with only a limited set of DVDs. The DVD drive is not powered by the Pi but using an external source.

As said I think I can rule out all hardware issues. My first guess is that the DVD scrambling is somehow involved due to the “Read of scrambled sector without authentication” message in dmesg.

No, I’m perfectly aware that you are using the same drive in both cases. We have occasionally seen this issue reported before so it’s not the first time I’ve seen it.

It still doesn’t change the fact that the system journal is reporting physical read errors though. We can’t do anything in software about the fact that the DVD drive is reporting physical sector errors when trying to read particular parts of the disk.

In all the previously reported cases the issue has been with the disk.

Why it plays on your ubuntu laptop (with Kodi ?) I can’t answer. Maybe when you play the disk under Ubuntu it doesn’t try to read the particular sector with an error. Just a guess.

In a parallel discussion the issue is also discussed.

The interesting thing is that it is perfectly possible to play the disc when it is mounted at command line. Could it be possible that a device specific issue is here at work?

A post was split to a new topic: Suspected spam