Problems with streaming and sound dropouts

I am new here and recently got a Vero 4K
Would need help with 2 problems, please.

  1. Problem: Picture and sound problems when playing 4K videos. It comes to picture stutter and sound completely fails (Atmos, DTS, etc.).

For 1 video this was the solution (I found it in this forum):



Unfortunately, many other 4k content still has these problems.

2nd problem: There are HDMI dropouts. The TV picture is often black for short and the AV Receiver Onkyo TX-NR646 display flashes briefly. It does not matter if I play 1080p or 4K content. With my Raspberry Pi 2 with LibreElec I did not have these problems.

For solutions I would be very grateful.

Device: Vero 4K
OSMC Version: October Update (2K17)
Protocol: SMB2 (network share mounted with Kodi)

Try fstab based SMB mount that has better performance

How are you connected to your LAN? Wired or wireless?

Have you tried a different HDMI cable? For this providing debug enabled logs will help.

Thanks for the support and solution suggestions.

I use an Ethernet cable. Problem # 2 was solved. Error was the HDMI cable.

But I can not mount with fstab. The log contains the error “mount: failed to parse mount options”

I started the Troublshooting with smbclient -L IP -U USERNAME
error: “protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE”

My NAS supports SMB2 / SMB3 protocol

How can I fix this?

Thanks in advance.

best regards,

Please post the contents of /etc/fstab.

Here is the content of /etc/fstab (username and password have been changed)

// /mnt/ds1m cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=user,password=pwd,uid=ds1m,gid=ds1m,file_mode=0770,dir_mode=0770 0 0

Looks fine to me. Just one thing: :t must all be one one line.

Let’s seem the output from:

ls -la /mnt
sudo mount /mnt/ds1m

Edit: I think you might need to change uid=ds1m,gid=ds1m to uid=osmc,gid=osmc

It does not work to change the values for uid and gid to osmc.

osmc@osmc:/mnt$ ls -la /mnt
insgesamt 8
drwxr-xr-x 3 root root 4096 Jän 1 2015 .
drwxr-xr-x 23 root root 4096 Okt 29 12:23 …
drwxr-xr-x 2 root root 0 Jän 1 2015 ds1m

osmc@osmc:/mnt$ sudo mount /mnt/ds1m
Couldn’t chdir to /mnt/ds1m: No such device

osmc@osmc:/mnt$ mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=803956k,nr_inodes=200989,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mapper/vero–nand-root on / type ext4 (rw,relatime,stripe=1024,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/bfqio type cgroup (rw,nosuid,nodev,noexec,relatime,bfqio)
systemd-1 on /mnt/ds1m type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=24,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=183220k,mode=700,uid=1000,gid=1000)

How can i remove the mounted network share (smb) from kodi? I can’t find any option with kodi.

There’s something very strange with /mnt. First, /mnt/ds1m has a creation date of 1 Jan 2015. Second, unless there is a copy/paste issue you have a directory with three dots (it should be two dots).

I suggest you run

sudo rm -r /mnt
sudo mkdir -p /mnt/ds1m

Sorry, the 3 points was a copy and paste error. the new creation of /mnt/ds1m does not work either. Very strange error. Thank you for your help. I really do not know how to continue troubleshooting.

Well, it would be helpful if you show us the error. The /mnt/ds1m directory seems to have a problem and needs to be removed. Here’s what is should look like:

osmc@osmc:~$ sudo mkdir /mnt/ds1m
osmc@osmc:~$ ls -la /mnt
total 12
drwxr-xr-x  3 root root 4096 Nov  6 21:43 .
drwxr-xr-x 24 root root 4096 Nov  6 21:30 ..
drwxr-xr-x  2 root root 4096 Nov  6 21:43 ds1m

Mine has a size of 4096, whereas your has a size of 0.

Try this:

sudo rmdir /mnt/ds1m

and let us see the output, if it fails.

osmc@osmc:/$ sudo rmdir /mnt/ds1m
rmdir: konnte „/mnt/ds1m“ nicht entfernen: Das Gerät oder die Ressource ist belegt

osmc@osmc:/$ cd /mnt/ds1m
-bash: cd: /mnt/ds1m: Kein passendes Gerät gefunden

Mine actually has also a size of 0

osmc@osmc-vero4k:~$ ls -lah /mnt
total 8.0K
drwxr-xr-x  3 root root 4.0K Jan  1  2015 .
drwxr-xr-x 23 root root 4.0K Sep 15 19:57 ..
drwxrwx--x  1 osmc osmc    0 Oct  9 21:04 server

Thats strange but it could be actually Kodi occupying it if you already added it to the library.
sudo systemctl stop mediacenter
sudo rmdir /mnt/ds1m

After deactivating the entry in /etc/fstab, I was able to delete the folder /mnt/ds1m. What should I try now?

Well I think we need to start from here

Can you check the log on your NAS when you execute this?
Actually I just tried myself limiting my server to SMB2 and I get the same error. So time to check on it.

Ok, found a solution.
sudo nano /etc/samba/smb.conf and in the section [global] add these lines

client min protocol = SMB2
client max protocol = SMB3

Ok @andi82 also for making it work via fstab you need to add vers=2.1

Yes, that’s the solution. You saved my day, thank you!