Problems with WiFi on Pi3 (weak signal)

My router is 5G, so it broadcasts two bands, standard and 5G. I connected to 5G after the system setup, all was working fine. Then I shut down the device, connected it to TV screen, turned on, all things looked like the connection was still working and yet, got errors during downloads or some streaming plugins. So I connected to my normal network, and it worked, after some time I started getting the same errors, so it looked like the same situation: system is connected to network but has no internet.

So I tried again connecting to 5G network and… can’t. It hangs on “Configuring…” for a few minutes, then it shows that connection failed. I tried many times and got the same results. Since 5G is faster, it’s better for streaming plugins.

So the issue here are:

  1. problems connecting to 5G network
  2. loosing internet while still being connected to normal (non 5G) network or often there is no internet from the start, status: wlan0 connected, then after a 10 minutes it changes to connected (internet finally working).
  3. during changing networks, quite often system either freezes permanently or crashes (blue screen with sad face) and see some error about unhandled exception - how changing wifi networks can crash system? this is absurd
  4. internet often seems very slow (streaming videos often buffer, reaction time after clicking is incredibly long, just seeing spinner) - it’s unusable, although I have fibre Internet up to 480 MB/s (tested and confirmed, even sometimes above that)

Note: my previous OSMC installation had no such problems, all worked fine. All other devices are connected without problems, so it’s not the issue with router.

Without a normal, stable connection, the whole device becomes useless, so this is a serious issue. I gave up on LibreElec just because it kept forgetting the passwords after the restart, which is also a big deal. Again, in previous OSMC installation all worked fine. Unfortunately, the SD card just died and had to install the system anew. This is frustrating.


I was wondering what has changed and:

  1. This is the same device (Rasberry Pi3)
  2. The same place (should have strong signal)
  3. The same system
  4. Different SD card… - now I am wondering, maybe this is the root of the problems?

I noticed that this system is freezing regularly for 1-5 seconds. This wasn’t happening on the old card. Can it be that this freeze is also the root of the buffering (system stops downloading for a moment), various delays and maybe the talking between devices (connection)?


Sounds like it may be a dodgy sd card. We would be able to tell more with some logs:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks Tom.


The log I got is:

grab-logs -A

This is the old log. The kodi.log is:

I guess, I’ll start looking for a proper SD card for my Pi, because bad SD is at least partially part of the problem.

I’ll also look for some command tool to check the disc and network performance. However, the fact that on different SD those things weren’t an issue is a strong indicator where the root of the problem lies.

Anyway, I was able to connect to 5G network today, but without internet. The second time it failed. The usual network is also dodgy. Once it has internet, once it doesn’t. Once the Internet works fine, once it’s slow. The fact that the issues are so random, it tells me that it’s not a software problem, or at least not entirely.

If you see anything in logs that gives some tips of what is going on, I would be grateful.


You should have been given a link, when you issued this commnd. This gives a full log.

But I still think its the SD card, I can recommend:


It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

Thanks Tom.

Yeah, I got it and paste it in the previous post. The line you quoted is a link. From what I see this is old log nevertheless. No idea why, but I pasted the kodi.log as well in the next link.

I just ordered a new micro SD card SDXC (with U3 speeds) so, it should be better than the one that I’m currently using (bought a long time ago).

P.S. From different topic, someone needs to improve widevine codec install. In order for it to work, the system must be upgraded, but it doesn’t happen automatically (even if automatic updates are on), which causes an issue if a user don’t know what is happening.

1 Like


Sorry I missed that.

It doesn’t look very happy at all. I would consider changing the PSU aswell, these can start to fail after sometime. It may also explain what’s happened to this SD card and previous one.

Apologies this is beyond my scope of knowledge. I suggest creating a new topic, to make it more visible to those in the know.

Regards Tom.

I installed the system on the new, fast microSD card. I could already see the faster responses of the whole system. However, all is fine when the system is new and… in my room. When I move it to the living room, magically all Internet issues appear, the same as before:

  • it connects with 5G network but there is no Internet
  • after a minute it disconnects from 5G
  • trying to reconnect fails
  • it connects to non-5G but… there is no Internet for a long time

This all points to the hardware problems with reaching the wifi. This is super weird, because wifi network is possible to connect 30-40m outside the building, so it’s very strong. My room is next to the router, ca. 2m away. The living room is ca. 6-7m away from the router and all devices have strong signal, all except Pi3 that is.

My question is, is Pi3 having incredibly bad wifi receiver/antenna? Do I have to buy something extra to make it stronger? With current issue, the Pi3 is completely useless.

Are there any Pi3 experts/users here? I’m a newbie to Pi3.

I can connect to my Pi3 with Samba or SSH, so there is Internet. However, when I try to do anything in HBO Max plugin, it throws me an error, as if Internet was not there.

EDIT 2: I found some usb-wifi dongles that might help, although…:

  • there is no guarantee it will work with the system/hardware
  • if the wifi is through usb2, will it have the speed limits of usb2? if yes, this will not be suitable for streaming like HBO


I would still try a different Power supply, a dying PSU can affect the transmit power of the wifi. Which may explain why it seems to work fine close to the router.

Some wifi dongles work out of the box, not all. Broadcom and ralink I believe.

USB 2 should be fine.

Regards Tom.

1 Like

Are there any cli tools to test out the power supply delivery (how much power it can provide vs. how much maximal power the device could need at some point)? I can recall some cli tools showing energy usage of various system hardware components, but don’t remember the name…

Thanks. I’ll check the power supply first, because if it’s not enough, the additional hardware that needs more power won’t help.

1 Like

Powertop, but that doesn’t tell you if your power supply has issues. For that you would need to test Voltage inline under load over some time.


Thanks. Maybe I can sum some energy usage and see if the power supply has power to handle more or is at its 70-80% capacity - that would suggest it’s too weak.