Providing diagnostic logs Vero 4k+

Hello, I was following Sam’s guide at: How to submit a useful support request - General - OSMC but can’t figure out how to get OSMC to save a log for me to interact with. I am currently troubleshooting an issue I am having with some high bitrate files.

I have enabled debugging within Kodi.

I cannot seem to do this bit:
“After opening My OSMC , navigate to Logs . Using this method will result in a URL link that you should provide so that others may be able to view.”

How do I go about saving the output from the log? should I SSH into the Vero box? Is it in a default directory, does it auto save to memory stick? Does it auto share with NFS or SMB?


You click on the logs icon (the one that looks like a clipboard), and select Upload Selected Logs Now

Type in the URL here.

I did click it but no URL showed up. I’ll try again today.

If your system has been running for a long time, the logs may be to large. Try rebooting twice and then send the logs when you reproduce your problem.


I am having the same issue. I activated the debug mode in kodi because I am facing the stutter issue and once I ve finished running the video file I simply couldnt upload the logs. First two times I did it via myOSMC the file was blank, so I restarted in debug mode and started to watch the video file again. Once Ive finished I just get < html > , doesnt matter what I select the log should contain. I tried in , seen in another thread here, the command via ssh and it seems to be completely random? grab-logs A didnt work, grab-logs J didnt work but grab-logs X somehow worked, but the log does not contain any “DEBUG” lines… I restarted the Vero4k+ , did again via SSH grab-logs A which didnt work but grab-logs J did… but unfortunately all the logs before are gone …

It seems very random to me, any help? Otherwise I wont be able to receive help for my other problem.

This happens then the logs get to large. As I said, reboot twice to clear the logs and then re-produce the problem.

In the future, we’ll increase the maximum log size to 100MB or so.