PVR change from SD to HD channel only audio.From HD to SD ok

HeyHo,

OSMC, raspberry and Silicon Labs Si2168 tvtuner DVB-T channels

When watching only hd or sd channels working fine
when changing from hd to sd channel working fine
but after changing from sd to hd channel bufferng time is long and after that only hd channel audio working, freezed picture from earlier sd channel left on screen.

Playback have to be stopped, and after that hd channels working again.

Tested Openelec also. Same thing.

Seems like bug to me, any suggestions how to fix this?

I can confirm that the same error occurs with dvblink for me.

I didn’t notice it only occured when switching from a sd- to a HD channel, but i just tested it, and it seems so.

I tried activating omxplayer, and deactivating mmal, but then my sd channels are with sound only and a black screen. HD seems to continually work fine.

Have you installed the mpeg2 codec?
This can potentially solve the problem. No guarantee though.

Not installed because I don’t normally need codec. So I haven’t bought it.
I can watch these channels without codec. Only problem changing channels as I described earlier.

hi,

which skin do you use? try to change to default kodi skin Confluence and se if the problem is there too.

and is it a pi1, 2 or 3 version, and what PSU do you use(amps).

But it is a known issue with tvheadend/kodi… it happens… with a good PSU, faster pi and use ethernet not wireless (if remote tvheadend) you can eliminate some of the time it happens.

-H

Hi,

Using Confluence, and I have tested this with pi2 and pi3.
I use usbhub with external psu, but have tried also without it.
Tvheadend server and client are running on this same pi.

This happens every time, so every time changing back to hd channet I have to first stop sd channel, and after that start hd.

And you are sure thats it’s not mpeg2 channels you watching? if mpeg2 and you don’t have hw codec licens for mpeg2 installed then it would be CPU that does the job and thats not a good idea even on a pi2-3.

maybe try what @Chrunchy says change to omxplayer just to test…

-H

1 Like

I’m no expert at codecs/players etc, but i got my issue resolved, so i’m just gonna leave my experience here.

It seems a bit strange, but it did in fact help me to install my mpeg2 license (havent gotten around to do that, after my latest re-install). However, from what i can read, my TV supplier stopped using mpeg2 for all channels, including their few SD channels since 2013. Don’t know how to confirm that myself though.

After i installed the license, upon playing any SD channel, the interface kept showing, that it was caching. When it got around to 100%, it started over with caching, and then over and over - the stream was playing fine with no stuttering, but i don’t wanna watch the interface showing constantly that it’s caching.

So i wen’t in and de-activated OMXPlayer, so only MMAL is activated, and since then my SD channels played fine, without caching, and i’m able to switch to a HD channel too without issues (i don’t need to stop the stream before being able to watch a HD channel now). If i activated both OMXPlayer and MMAL, the issue re-occured with caching, but i was still able to switch from a SD channel to a HD channel without issue.

Hope it helps. I would say buy the mpeg2 license - they don’t cost that much (2.40£ - http://www.raspberrypi.com/mpeg-2-license-key/ )

Well, after adding the license it really works. Although does not explain why channels doesn’t work after changing back and forth channels. License is kinda commercial workaround.

Btw, I added exactly this same question to openelec boards. Not a single answer.

So thanks for your trobleshooting help.
Still don’t know is this kodi, tvheadend or osmc bug but atleast channel jumping is a joy again :slightly_smiling:

Edit: btw this si2168 dvb dongle works only after addin drvers manually like in the post linked, altough should be supported in osmc, otherwise dvb-t channel scan fails at tvheadend