PVR / IPTV Stream switching causing OSMC crash, reboot stall

While one IPTV stream is playing, switching to another one carries a high risk of crashing OSMC. Not only that, it will be impossible to restart via SSH. A complete reboot is also not succeeding, the device halts after “Reached target Shutdown”, after several minutes turning off the display. Only solution is cutting off the power.

I suspect this also happens with other streams such as Youtube videos but so far didn’t capture logs when it does.

This log shows the time where it happens, remote inputs are still being registered after attempting to switch but the screen has turned black and the debug info will already be frozen.


How are you issuing that reboot? Seems you may be trying to shutdown instead

Since OSMC isn’t controllable at that point, by calling the reboot command via SSH, something that never let me down before :sweat_smile:

If you call it during normal operation, does it reboot OK?

Absolutely. Only after this particular event does it not work anymore.

I do have refresh rate adjusting set to on start/stop, is it possible that the hang occurs because the frame rate differs between streams?

2019-07-07 18:54:13.156 T:3743343328 DEBUG: CVideoPlayerVideo - video decoder returned error
That is the problem.
Can I get full logs?

Full logs: https://paste.osmc.tv/izehiyepox


Debug logs appear to be disabled, also the log doesn’t appear to show the issue.

From looking at the first log, if you disable hardware acceleration make any difference?

Some iptv don’t play well using the GPU.

Thanks Tom.

New logs: https://paste.osmc.tv/agoyojekal

For this test I first disabled hardware acceleration as suggested, then switched channels. I then enabled it again and tried to repeat the same. After a couple switches OSMC froze.

Thanks for confirming that the issue also occurs with software decoding.

Is that what the logs show? Because without acceleration OSMC did not freeze. Only after turning it back on. Just to avoid any confusion.


Looks like there may be issue with encode of the streams, try setting Accelerate h264 to hd & up.

Thanks Tom.

The streams are all 720p, would the setting still have an effect?

Here is the debug log after OSMC froze on the first attempt to switch channels, with that setting changed to HD and up: https://paste.osmc.tv/aqowuwihaj


In the short term I think you going to have watch these streams with hardware acceleration off. Not sure if this is something @sam_nazarko can fix in the future.

Thanks Tom.

I’ll check this after I get back in the UK tomorrow

Okay, thank you for your assistance.

I suppose there is no way to disable acceleration only for PVR to avoid this issue.

No sorry

Could this be specific to the Vero4K+, or maybe a hardware fault? I have tried the same IPTV configuration on an Vero4K and there are no crashes after several minutes of stress testing.

The only obvious difference between the two setups, the 4K is directly connected to a TV, the 4K+ to an AVR. Once more trying without adjusting refresh rate change, or disabling the audio keep alive setting, same result. The 4K+ keeps crashing.

Can you confirm both are connected to the same switch etc?

Are both on the same software version?
You could copy the working userdata from the good device to the bad one as a test


The devices are both connected to the same network via ethernet, the 4K directly to the router, the 4K+ with a switch in between.

Copying the entire userdata from 4K to 4K+ yields the same result. Instant crash on the first attempt to change channels.