PVR + Live TV Freezes

Hello. I’m not exactly sure when this started, but my RP/OSMC rig has started having serious issues with PVR and Live TV.

PVR - After watching recorded shows for 5-10mins, image will freeze and system will become unresponsive, then the screen displays a series of predominately green vertical stripes. I have to unplug power to reboot. No log to upload.

Live TV - Intermittently, picture will freeze after ~10mins or so, but respond to remote commands. See log at https://paste.osmc.tv/dutivegevi.

Thanks in advance for any assistance!


COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_splitter wait event timeout

Try disabling hardware acceleration and see if the issue persists.

Thanks Tom.

+1 I never had much luck with OMX. The other option works better for me.

1 Like

Thanks for the replies – i disabled hardware acceleration but no improvement (and movies became unwatchable).

Similarly, if I leave TV playing for an extended period, say overnight, the image is frozen when I turn the TV back on and have to reboot.

Should I try to load a prior release?

Sorry to be a nag, but this situation persists – I’m having to reboot the device several times a week (see most recent log at https://paste.osmc.tv/afufejeros).

I’m about ready to try a rebuild, is there a specific release I should go with?

Thanks for reading!

Sorry for the delay - the alert system can’t be working right. Can you try another power supply (the green stripes might suggest that). Then before re-imaging, you could try deleting or renaming .kodi then re-booting so your kodi settings are all re-set. Also, you didn’t say whether you tried MMAL acceleration.

I would just download the latest. I don’t think this is version related.

Thanks for the quick response! I turned on MMAL, so both it and OMX were ‘on’. Same story. I rebooted (remove power connection and reconnect) and turned OMX ‘off’ while leaving MMAL ‘on’ to see what happens there – I will advise back with those results (and suppose I can also play with the Overclock settings as well).

Continue fail. I re-installed OSMC and only configured for Live TV with MMAL on and OMX off – that worked fine until I changed audio settings to TV+Analogue – freeze city. Reverted, and still the occasional freeze. Re-imaged again with TV and MMAL, things seemed fine so added links to movies and ripped CDs – seemed ok until I changed audio settings again. Crash again. The last log is at https://paste.osmc.tv/uciruzogun – I’m starting to think it’s a bad RP3B board, but I would appreciate one more set of eyes on the log in case I’m missing something.

Thanks in advance.

Well, it looks like the log is empty – despite turning on all the flags before the freeze (unit did not crash before sending the log).

I’ll be danged.


I’m assuming you’ve rebooted after the crash, so you could try:

cat /home/osmc/.kodi/temp/kodi.old.log | paste-log

And provide the new url or if there was no reboot:

cat /home/osmc/.kodi/temp/kodi.log | paste-log

Thanks Tom.


If you haven’t already try replacing the power supply as advised by Graham above and a new sd card.

Thanks Tom.

Tom - Thanks for your reply.

I’m using a 5W 2.5A psu that came with the kit, but can look for a replacement for test purposes. I’ll also capture another log, then prolly re-image (again) and test incrementally until I hit a derp (TV only, TV w/audio change, adding content links, etc.).

Update - TV playing normally with audio output set to HDMI+Analogue, then audio dropped – about 12 seconds later, the picture froze and I pressed ‘STOP’ on the remote (it took several commands from the remote for OSMC to respond and revert back to the channel guide). This has been the typical scenario with this particular issue.

  1. According to the log at https://paste.osmc.tv/dacugikafa, it looks like here is where the troubles began -

• 17:57:54.848 T:1886384896 ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_splitter wait event timeout

• 17:57:54.848 T:1886384896 ERROR: CAESinkPi::AddPackets timeout

  1. Then a new error started to appear -

• 17:57:58.978 T:1886384896 ERROR: CActiveAESink::OutputSamples - failed

  1. After the third “CActiveAESink::OutputSamples - failed” error at 17:58:09.428, it looks like the Win7 PC running Kodi/ServerWMC shut things down -

• 17:58:10.696 T:1925972736 DEBUG: CAnnouncementManager - Announcement: OnStop from xbmc

• 17:58:10.696 T:1925972736 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop

Unfortunately, I don’t know what it all means besides “she don’t work so good”. This only happens with TV, and apparently when audio output is set to HDMI+Analogue (straight HDMI seems stable).


Try changing the output configuration to best matched, under the audio settings.

Thanks Tom.

Tom - Hi, thanks for the suggestion (it makes too much sense!). I’ll give it a go and advise back.

Alas and alack, switching to ‘best match’ had no effect. I’m afraid it might be time to throw in the towel and start over with a new rig.

Thanks for your help!


I would try adding a video cache, doesn’t work with all pvr addons; but it may help:


I use these settings on my pi3:


Could try read factor 5 aswell, Also I believe a new update for osmc will be landing soon; I would try with MMAL instead of OMXplayer after its release.

Thanks Tom.

Sorry for the late reply – I just sucked it up and re-installed OSMC, got it configured the way I want with the Mimic skin (better WAF) and all is well. I am using HDMI audio only to the TV and pulling audio for BT transmission from the TV analog audio port – everything is stable and clear as a bell, and the jitter/static is no longer present over the BT speaker, which tells me there’s something wrong with either the actual analog audio port or its drivers. Plus this config also broadcasts other TV inputs (BD player, Chrome) to the BT speaker.

Thanks for helping!