"PVR manager is starting up" warning and no EPG

I am new to OSMC and am having problems getting the EPG to work.
It is running on a RPi3, using version 2018.03-2 on a 32G microUSB card, TVHeadend and Hauppauge 292e receiver.

I have just re-installed the system and when I go to “PVR & Live TV” on the OSMC interface on the RPi I get a message “PVR manager is starting up” and I don’t get an EPG. I don’t get access to live TV.

I can get in from a web browser on port 9981 and there I do get an EPG and I can even record a TV programme to my disc.
I can also get in from SSH and can “see” the file system including my recordings ( I have made two!).

Last time I built the system during the TVHeadend setup on the web:9981 interface I had set the “Allowed network” as, I read a posting that reckoned that was wrong, so I re-formatted the SD card and re-installed everything and this time I set the “Allowed network” as, However, it hasn’t fixed my issue.

Any suggestions on what I am doing wrong?


I would try setting the allowed access as, unless you are port forwarding on your router; its still only accessible from within your lan.

And make sure you have set a username & password in the Tvheadend HTSP Client plugin, the default is osmc osmc.

see here for more details:

Thanks Tom.

Thanks Tom.
That guide is great! As you guessed my problem was that I hadn’t entered the user id and password on the OSMC-Settings-Add-on Browser-My add ons- PVR Clients-TVHeadend Client-Configure. I put that in, did a reboot and the TV channels came up - BRILLIANT!

The guide I had been following was from “The Official Raspberry Pi Projects Book” and an article by Clive Webster. It is a good guide, but I guess it has become a bit out of date.

It is using the ip address, so at least that works.

Anyway, thank you very much.
Fingers crossed can keep it going and don’t screw it up …

1 Like