[Q] Getting GPIO MCE IR Receiver to work!

Hello all,
I am struggling to get the IR receiver to work on my new RPi 2 running OSMC RC. I installed it in the same way as my old original Raspberry Pi.

I enabled the option under RPi settings. Selected the correct LIRC remote config under “Remotes” but i still can’t get it to work.

dmesg | grep lirc returns this:
[ 7.733669] lirc_dev: IR Remote Control driver registered, major 246
[ 7.754351] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.710663] lirc_rpi: auto-detected active high receiver on GPIO pin 17
[ 8.711118] lirc_rpi lirc_rpi: lirc_dev: driver lirc_rpi registered at minor = 0
[ 8.711138] lirc_rpi: driver registered!
[ 9.471707] input: lircd as /devices/virtual/input/input4

What am I doing wrong? Any suggestions as to how I can fix this and get it to work? It worked perfectly under Raspbmc.

Thank you in advance

What remote do you have?

HP MCE Remote

In MyOSMC system settings where you enable remote support change the input pin to 18 and output to 17 then retry

Thank you @Dilligaf that worked beautifully. I’ve followed the instructions for the original RPi with regards to the GPIO.

Dilligaf, I’m running RC on a pi2 also don’t see an option to change the pin in the MyOSMC. Am I looking in the right place?

Should be in PiConfig, are you running RC1 from a fresh install and not updated from an Alpha?

Dilligaf, I just did a fresh install of RC1 just as a sanity check, but still I don’t see the option in Pi Config.

I’m looking in “Settings - Pi” / “Hardware Support”

I only see

“Enable LIRC GPIO support” I made sure this is checked
“Suppress all overlays”

Under “w1gpio” there are only three options
the other two are something about overlays and overlay with pullup.

I don’t see anything about pin numbers.

Have you installed any updates?

Nope no updates.