Question mark icon in finder on samba share after upgrade to Buster

Zrzut ekranu 2020-10-20 o 22.09.50

Hi, after the upgrade I have a question mark icon on OSMC share. I reinstalled smb-app-osmc but it gave no effect. Preferably, I would like to get rid of the OSMC share and keep only Samba shares on OSMC. When I commented out
the following part in /etc/samba/smb.conf

  35   │ #[osmc]
  36   │ #    browsable = yes
  37   │ #    read only = no
  38   │ #    valid users = osmc
  39   │ #    path = /home/osmc
  40   │ #    comment = OSMC Home Directory

it didn’t make OSMC question mark vanish.

What makes you think the ? is related to Samba?
What is shown if you open “Samba Shares on osmc”?
What happens if you click the ??

When I stop the samba service ? disappears.

Inside there is osmc (the one from config I pasted in the the first post) plus my external drive. So that’s ok.

Clicking the ? is really interesting as it shows exactly the same content that Samba Shares on osmc” does.

Could this be finder picking up UPNP or similar?

I ran VLC on my smartphone, went to the local network and it clearly indicates that OSMC is smb


smbutil status                                                                                          
Using IP address of
Workgroup: WORKGROUP
Server: OSMC

smbutil view //osmc@
Share                                           Type    Comments
osmc                                            Disk    OSMC Home Directory
IPC$                                            Pipe    IPC Service (Samba 4.9.5-Debian)
My Passport                                     Disk    Auto-mount Volume

So it looks like OSMC is the entire host but for some reason it is treated as samba share as well…

Just guessing here, but is your hostname OSMC?? then finder can’t identify the hardware on the hostname OSMC thereby giving it a “?”, and clicking it enters the first share or share that has the same name as hostname?

Not a Apple person so i have no actuall idea.

My hostname is osmc <- no capital letters there. It makes sense what you’re saying. Before the upgrade OSMC had the same icon as Samba shares on OSMC has now. It’s not a big deal though. I will keep on looking for a solution, don’t like this ? at all…

Well google might be our friend, here seems to be a solution for that pesky “?”. Open a ssh session to your OSMC device:

sudo nano /etc/avahi/services/samba.service

add this to the bottom of the file, before “”


As i said haven’t been able to test this since i got no Apple, and I’m not sure if avahi on OSMC supports device-info.tcp


Screenshot 2020-10-21 at 11.55.02

Thank you so much, no more ?. Is there any chance to get rid of OSMC entirely?

Disable avahi

My joy was too sudden. It got back to a question mark icon. However, I discovered that OSMC is not connected with /etc/avahi/services/samba.service in any way. When I changed the name of it to /etc/avahi/services/samba.service.bak only Samba shares on OSMC disappeared. It looks clearly that OSMC is connected with avahi-daemon. I tried to change host-name in avahi-daemon.conf and restarted the daemon, no change, OSMS left.

What I’ve gathered the avahi/services/samba.service just informs avahi that there is a samba service running on the box.

Finder ask avahi first what is there, and avahi answers: OSMC + as amba service running with these shares.

Inorder to remove the OSMC icon, try stopping avahi service,

systemctl stop avahi.daemon

I’m unsure what this will do to the rest of your network that relies on avahi on your OSMC device. Or any service on the OSMC device that relies on it aswell.

This might make your samba browsing on the Apple device(s) ALOT slower

Stopping of avahi.daemon deletes OSMC along with Samba shares on OSMC. I want to keep the latter for fast access. I am not giving up. I will post once I find something.

Setting disable-user-service-publishing=yes in avahi-daemon.conf leaves only Samba shares on OSMC. So it looks like something else is using avahi to advertise OSMC

Here is what’s behind OSMC

avahi-browse -a | grep OSMC
+   eth0 IPv4 OSMC                                          _device-info._tcp    local
+   eth0 IPv4 OSMC                                          Microsoft Windows Network local

Stopping samba service makes OSMC disappear.

In samba service logs:

Oct 21 14:05:49 osmc nmbd[9209]: [2020/10/21 14:05:49.219946,  0] ../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
Oct 21 14:05:49 osmc nmbd[9209]:   *****
Oct 21 14:05:49 osmc nmbd[9209]:
Oct 21 14:05:49 osmc nmbd[9209]:   Samba name server OSMC is now a local master browser for workgroup WORKGROUP on subnet
Oct 21 14:05:49 osmc nmbd[9209]:
Oct 21 14:05:49 osmc nmbd[9209]:   *****

I cannot find OSMC anywhere in the samba config.

@joakim_s @fzinken any ideas gents?

In order to change the question mark to something else just add

fruit:model = RackMac

in [global] section in /etc/samba/smb.conf

What versions of MacOS are affected by this and what has changed to cause this ? We have not updated the smb.conf during the buster migration or indeed for a while.

Also what’s the reason for choosing RackMac as the icon over other types, and will this be backwardly compatible with older MacOS versions ? I only have one model of Mac and MacOS version that I could test with.

My version back then was Catalina. My understanding is that during the buster migration samba got bumped and that caused that. You can choose whatever icon you like I posted a rack icon as an example. Some available options I found googling:

fruit:model = iMac
fruit:model = MacBook
fruit:model = MacPro
fruit:model = Xserve

In terms of compatibility with older MacOS version I don’t know :slight_smile:

Ok I’ve been having a look at this - there are a lot of models recognised in MacOS Catalina, and to be honest I find the RackMac one a bit ugly, so here are some of the options available and their string name:


Previous versions of Samba (on Stretch) use the Windows (BSOD) icon at the bottom right but I think we can do better than that. :slight_smile:

My opinion is the Macmini icon is probably the most apt as it looks most like a Vero and a Mac Mini is often used as a file server, so it sort of fits, and it will stand out from other Windows PC’s on the network.

But I’d be interested to hear what other people think especially @sam_nazarko as to which icon we go with… as far as I’m aware this setting only affects the icon displayed and has no functional effect.

+1 for Mac Mini

  • 1 Mac mini

Macmini it is then.

1 Like