r-Piv4 8GB fresh install of OSMC_TGT_rbp4_20230729.img

Black screen post install.

Did a fresh install of OSMC_TGT_rbp4_20230729.img onto a new r-pi v4.
The initial boot/partitioning seemed normal. After the first reboot, the screen gets no HDMI output.

Last week, I screwed around with the config.txt options hoping to resolve it. None worked. Re-created the fresh image over, test, repeat at least 20 times.
This morning decided I needed help from experts.
https://paste.osmc.tv/uqedemonaj has the logs from just after a fresh install and first reboot. Seems stuck in a loop:

2023-08-27 13:05:56.989 T:519     error <general>: ActiveAE::InitSink - returned error
2023-08-27 13:05:57.490 T:520      info <general>: CActiveAESink::OpenSink - initialize sink
2023-08-27 13:05:57.490 T:520     error <general>: CActiveAESink::OpenSink - no sink was returned
2023-08-27 13:05:57.490 T:519     error <general>: ActiveAE::InitSink - returned error
2023-08-27 13:05:57.990 T:520      info <general>: CActiveAESink::OpenSink - initialize sink
2023-08-27 13:05:57.990 T:520     error <general>: CActiveAESink::OpenSink - no sink was returned
2023-08-27 13:05:57.991 T:519     error <general>: ActiveAE::InitSink - returned error
2023-08-27 13:05:58.491 T:520      info <general>: CActiveAESink::OpenSink - initialize sink
2023-08-27 13:05:58.491 T:520     error <general>: CActiveAESink::OpenSink - no sink was returned

The pi is connected to an HDMI switch connected to a 1080p monitor (for now) that supports PCM audio only. I’ve been recording the screen from mid-install, if that would help.

Got a quality, new, 4K microHDMI-to-HDMI cable a few days ago and it did seem to make a difference from the micro-to-full HDMI adapter.
ssh is working fine.


Last week,
the same image, used in the same way did let me into the KODI interface for a period of time. I’d even been able to add my source areas and install the Jellyfin add-on.

When I moved it to the projector room, it never came up.
I assumed it was bad HDMI cables. The boot said a file system wasn’t closed properly, so I connected the microSD to my linux workstation and ran fsck on the file system. No errors were found or fixed. After that, only the boot rainbow and 2-3 lines (I’d call them grub lines, but do ARM systems even use grub?) are shown before HDMI video ends. The monitor says “no hdmi signal”.


This morning with another fresh install, 2nd boot shows the rainbow and the monitor says “no hdmi signal”.

The monitor works with other HDMI inputs. For example, a roku plays find with it with stereo (no fancy DD+ audio supported).
I tried the last settings in this old thread. No picture after logo on Rpi4 - #13 by PapaLazarou

Anyway, the logs should show a freshly installed system, nothing else. No customization. And no video output.

Please help me Obi Wan. You are my only hope.

Which of the two ports are you connected to?

Try this in guisettings.xml

    <setting id="videoscreen.resolution">21</setting>
    <setting id="videoscreen.screenmode">0192001080050.00000pstd</setting>

First stop Mediacenter, edit the file and start Media center

sudo systemctl stop mediacenter
nano .kodi/userdata/guisettings.xml
sudo systemctl start mediacenter

Thanks for the FAST response! I made the changes, restarted, the screen didn’t come up, but the systemctl status claimed it was running, so I rebooted. After the reboot, the guisettings were put back!? Huh?

I’ve been a Unix/Linux admin for 25+ yrs.
Let me try this again.

  <setting id="videoscreen.resolution">21</setting>                                             
  <setting id="videoscreen.screenmode">0192001080050.00000pstd</setting>                                 
    <!-- setting id="videoscreen.resolution" default="true">16</setting -->          
    <!-- setting id="videoscreen.screenmode" default="true">DESKTOP</setting -->

Ok, checked it again. settings were in there when I restarted media center daemon. No HDMI output. Let me reboot now. … I’m using
sudo shutdown -r now

See the OSMC splash screen, then No HDMI Signal from the TV.
Other ideas?

Which HDMI port are you using?

The one closest to the power plug - hdmi:0.

Doesn’t hurt to ask. I may have done something stupid. Never know.
I haven’t tried any other OS on the Pi and it was the very last one in stock, though the box was still sealed. Got it from MicroCenter … checking stock on a whim. Also got heat-sinks, a fan, metal case and a pi4 power adapter. Nothing makes me think there are any power issues. I had power issues with pi2 and pi3 models.

Whats the output of /usr/bin/edid-decode /sys/class/drm/card1-HDMI-A-1/edid ?


$ /usr/bin/edid-decode /sys/class/drm/card1-HDMI-A-1/edid 
EDID extract of '/sys/class/drm/card1-HDMI-A-1/edid' failed: unknown format.

BTW, this is still booted with the guisettings modification. Let me check that those are still in the file…
Yep, they survived the reboot, but the comments were removed. I guess that’s a different problem.
$ egrep ‘videoscreen.resolution|videoscreen.screenmode’ guisettings.xml
21
0192001080050.00000pstd

That screenmode string seems a bit odd. Wouldn’t something like 16 be expected?

cat /sys/class/drm/card1/card1-HDMI-A-1/status
cat /sys/class/drm/card1/card1-HDMI-A-2/status

$ cat /sys/class/drm/card1/card1-HDMI-A-1/status                          
disconnected
$ cat /sys/class/drm/card1/card1-HDMI-A-2/status                          
disconnected

Let me get the HDMI switch out of the middle. Or perhaps I should turn up the hdmi power output, since when I do finally connect it to the projector, that HDMI cable run is 20ft.

Direct connection first. Give me a second.

Ok, seems the port on my hdmi switch might not be good or it is lying about the type of monitor connected. It is a 4x2 matrix htmi 4.0b switch.

Let me see if everything else is working now. The mouse and keyboard don’t work, at least not through my KVM-switch. I need to do some troubleshooting, though there usually isn’t any keyboard or mouse connected to my OSMC systems.

I think the video output is solved. I wonder if the defaults would have worked as well. Hummm.

BTW, just so others know what it should have looked like:

$ cat /sys/class/drm/card1/card1-HDMI-A-1/status           
connected
$ cat /sys/class/drm/card1/card1-HDMI-A-2/status           
disconnected

Thanks so very much! Won’t take a second to put the guisettings back and reboot. See what happens.

And now also
/usr/bin/edid-decode /sys/class/drm/card1-HDMI-A-1/edid
should work

Just rebooted with guisettings as the defaults. Worked fine.

Yep, the EDID stuff is working too. Far too much output to post, but

    DMT 0x52:  1920x1080   60.000 Hz  16:9    67.500 kHz 148.500 MHz
  Detailed Timing Descriptors:
    DTD 1:  1920x1080   60.000 Hz  16:9    67.500 kHz 148.500 MHz (521 mm x 293 mm)
                 Hfront   88 Hsync  44 Hback 148 Hpol P
                 Vfront    4 Vsync   5 Vback  36 Vpol P

It was a cheap 2nd monitor. Need to try the other HDMI switch ports and perhaps turn up the HDMI power from the PI. No other computers or the Roku had issues with the HDMI switch. Might be a power thing there.

Looks like the Pi doesn’t like my KVM switch. Keyboard and mouse not working. That’s fine. I live in ssh.

As usual, there’s no way for someone to guess/assume my complex KVM switch and HDMI switch setup and the issues that might cause. Almost took beating me over the head to get me thinking something that works with everything else might be the issue.

Anyway, this is solved.

So, I kept testing attempting to get the pi video through my hdmi switch, since that is basically a requirement for me.

<deleted about 10 different troubleshooting attempts> tried different ports, different cables, with and without an hdmi recorder. Verified that the ports and cables all worked with a roku.

Ok, all of that was a rabbit hole. The lack of HDMI output was tied to there no being any input device connected. No keyboard. No mouse. No remote. Of course, I didn’t know this. But before I moved everything to the projector and tried there, I setup an MCE-RC6 remote over ssh … just a quick delete of a symlink and re-link in /etc/lirc/ … worked perfect.

Rebooted. Didn’t really expect much, but not only did the remote work, but the HDMI output worked AND sound came from the cheapo-monitor speakers. Read that again.

No input devices meant that the HDMI port was disabled.

Why would that be? I tend to use an old Android tablet to control OSMC either through the web interface or through a jellyfin client program.

Figured this was important enough to post.

Just to throw an alternative out there you could push a resolution change via a web browser instead (changing the ip and port to match Kodi’s web interface setting of course)…

http://192.168.254.0.10:80/jsonrpc?request={"jsonrpc":"2.0","method":"Settings.SetSettingValue","params":{"setting":"videoscreen.screenmode","value":"0192001080050.00000pstd"},"id":1}

The web interface wasn’t available in the beginning. The mediacenter daemon failed to start, so no web-api would be there.

1 Like