Rain-like noise in 4K movies

#1

I’m experiencing rain like noise on the dark parts of 4K movies. This is a sample from Prometheus: https://www.youtube.com/watch?v=ev4g0Irua1c

What could this be?

#2

Can you post some logs?
How is your audio configured?

#3

That kind of sounds like noise floor. To make that happen I think you would have to have the volume inside of Kodi turned almost all the way down and an external amplifier turned up very high to be hearing that much though.

#4

This is why I suspect he has PCM output enabled, rather than passthrough.

#5

Ok. I need te be more clear. I’m talking about VISUAL noise as you can see in the video I attached. It’s only with 4K movies.

#6

That looks like natural grain.
If you see white sparklies, change your HDMI cable

Sam

#7

Maybe it’s not clear enough in my video but it looks like it’s drizzling all the time. The noise constantly moves down. Once you notice it, the movie becomes unwachtable.

#8

Is that the only video that this happens with? Did you rip the video yourself or get it from other sources?

Mediainfo for the video would help, and logs after the problem happens are really needed.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. since mediainfoonly needs to read the header information of the file data, copy the first 4 Mbytes of the media file to a new file:
    dd if="<media file>" of=purgeme.bin bs=1024 count=4096
  5. upload the decoded media information using
    mediainfo purgeme.bin|paste-log
  6. publish the returned URL here in this topic
  7. remove the created media file snippet
    rm purgeme.bin

Thx for your help.

#9

Here are my logs:
https://paste.osmc.tv/uqezoribar
https://paste.osmc.tv/pebakoqubo

It’s not just with this movie. It’s with all my 4K videos and most clearly on a greyish and static background like in Prometheus at 15 minutes in the movie (the hangar-scene). I tested the same movie on my PC with MPC-HC and it looked normal.

#10

TBH it sounds like electrical interference.

#11

Wouldn’t that be visible on HD-movies too then?

#12

As Sam suggested - try a different cable. If the issue changes then at least you know the cable is a factor. I would guess that 4K will be affected more easily than HD by a slight cable problem.

#13

I tried 4 other HDMI-cables and other HDMI-inputs on my LG OLED65B6P and the results are all the same. The weird thing about the noise is that it moves so clearly from the top to the bottom like it’s raining (and no, there’s not rain in the movie here).

#14

Do you see it in the interface?
Do you only see it at certain resolutions?

#15

It might be worth looking in your TV’s menu to see if there is any kind of ‘visual enhancement’ features turned on. I’ve never seen what you describe but I have seen odd interactions.

#16

Oh my. I found the problem. Settings > Display > Resolution was set to 1920x1080. I thought I had read somewhere here that I was supposed to set it like this to prevent problems, but it caused downscaling of the 4K movies. It makes sense now I realize this.
Setting the resolution to 3840x2160p fixed it all!

#17

did you set also refresh to stop start when it was in 1920/1080p 60?
Settings>Player>Videos>Adjust display refresh rate
cause gui is not 4K.

https://kodi.wiki/view/Settings/Player
you also must have settings in expert mode

#19

You shouldn’t change the GUI to 4K
Instead set it to 1080p and enable adjust refresh rate

#20

If you are using a whitelist then Kodi will ONLY use those and the UI resolution@framerate.

#22