Rainbow Screen on Startup

I’m using a Raspberry Pi 2 and installed OSMC on a 16 gig SD card. I used the Windows installer and walked through the wizard. It said the installation was successful. I tried booting the SD card on the Pi a few times with the same results; just the “rainbow” colors covering the whole screen. Then tried a NOOBS install on to the same SD card just to make sure everything was working fine with the hardware. NOOBS installed fine and booted up on the Pi. Please tell me what I need to do, or what I’m doing wrong.
The OSMC version was the latest - 2017.02.17.
Thank you,

You may have selected the wrong image.

Thanks for the fast reply.
No, not wrong image.
It was under the Raspberry Pi listing.
IMG = OSMC_TGT_rbp2_20170210.img.
Is this correct?

It’s correct.

You may have imaged the device incorrectly. Why not use the Windows, Mac or Linux installer?


Yes, I used the Windows installer and walked through the wizard. It is very straight-forward. When finished, it said it was ready to use. I thought there might have been a problem with the Raspberry Pi, itself, so I downloaded the latest Raspi Jesse image and put that on the SDcard… That booted up on the Raspberry Pi just fine.
Any other suggestions?

What power supply?

It came with the Pi. I believe it is a 5A output.
I’ve been using it for a couple of years.

Post a picture of the Pi

Believe 5A? Or is it 5V and 1A? I’m asking because the details matter and your response isn’t very clear or confident…