Random crashes

I have crashes on all playbacks.

Sometimes it just drops out of the movie, other times the interface crashes completely and a hard reboot is needed.

I have attached logs of from the last time it happen.

The same files plays without issues in my Nvidia shield.


Any ideas as to why this is happening?

Its running the latest version.

You have not enabled debug logging. We need more verbose logs.

15:09:13.488 T:3655332608 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true

How are you streaming these files? It looks like you’ve mounted to /mnt. Can you try playing the file back locally, and posting your /etc/fstab?

I have enabled debugging to next time.

The files are streamed from my samba server over wired connection to the Vero 4K.

Fstab looks like this:

//xxx.xxx.xxx.xxx/storage /mnt/storage cifs noauto,x-systemd.automount,username=xxxx,password=xxxx 0 0

Is the Samba machine windows or a NAS?
Is local playback Ok?

Its a debian linux.

I’ll see if I can find a USB key to transfer the file to and test from it.

Since the crash seems random, is it then possible to enable debug in kodi but not have the on screen display running all the time?

Check here:

New logs:

This is playing over network (samba)

Is it SMBv2? I believe I have a fix for this.

12:29:13.248 T:3682726656  NOTICE: CVideoPlayerAudio::Process - stream stalled
12:29:15.005 T:3867202304   ERROR: ffmpeg[E680D300]: [matroska,webm] Read error

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Definitely a improvement.

Just watched a movie without any issues, that wasn’t possibly before.

Though it then crash again one a episode I watched after.

The improvements were mainly for Kodi’s built in SMB mounting. I just saw in your logs you are using fstab based mounts. There are also some CIFS improvements there too.

When you say crashing, I assume you mean playback is just stopping?

Can you try using Kodi’s built in SMB client to see if this helps temporarily; and can you clarify your SMB version?

The server is running SMBv2.

Just tried to use the build in SMB client to watch a movie, this also didn’t work as the picture would flick on off suddendly. Not sure that is related though.


With crashing, I mean that the interface stops responding to input and I have to reboot the Vero4k.

I’ll try with local playback now to see if that changes anything. hopefully I have USB key that is big enough :slight_smile:

Do you have a chance to use SMBv3?

Yes, I tried SMBv3 last night, I can mount the share in kodi but when I try to browse the share, I get a error: file exists

local playback worked fine btw

I think File Exists is an authentication error IIRC.
The playback stops because of an issue with SMB. It’s not clear what’s happening, but it looks like the connection is getting reset or dropping.