Random Freezes RPi2

Hi, I seem to have a recurrent freeze problem with my OSMC on RPi2.

I have syslog-ng installed and this is my /var/log/error

and this is my /var/log/kern.log

The issue starts at 23:42:15 in the logs file. Looking at my snmp monitoring I can see that is the exact time when snmpd stops reporting to my snmp sensors, however the ping (ICMP) monitor is green until it dies just around 03:30 in the morning.

The box keeps going with very limited capabilities at this point until 4:40 which is when the error logs stop completely, I do however see more log lines on /var/log/syslog and /var/log/daemon.log file until 4:53 which I think it’s the actual time of death (no useful information in those logs though I think from what I can see)

Is anybody able to point me in the right direction?

just to mention a couple of key error logs:

May 12 01:00:02 pi-osmc-lon-lr kernel: Unable to handle kernel paging request at virtual address 1fad2090
May 12 01:00:02 pi-osmc-lon-lr kernel: pgd = 82ae0000
May 12 01:00:02 pi-osmc-lon-lr kernel: [1fad2090] *pgd=00000000
May 12 01:00:02 pi-osmc-lon-lr kernel: Internal error: Oops: 5 [#8] PREEMPT SMP ARM
May 12 01:00:02 pi-osmc-lon-lr kernel: Process ps (pid: 31641, stack limit = 0x82b8a238)
May 12 01:00:02 pi-osmc-lon-lr kernel: Stack: (0x82b8bd88 to 0x82b8c000)

May 12 01:15:45 pi-osmc-lon-lr kernel: INFO: rcu_preempt detected stalls on CPUs/tasks: {} (detected by 2, t=544332 jiffies, g=2245697, c=2245696, q=146209)
May 12 01:15:45 pi-osmc-lon-lr kernel: INFO: Stall ended before state dump start

Any idea why this could be happening?

What overclock are you using, and if you are using faster than “Normal” have you tried dropping it back to normal ? You don’t see any coloured squares in the top right indicating low voltage do you ?

This is a kernel oops, which is pretty unusual.

What additional hardware do you have connected, and do you have any additional software (outside of Kodi) installed, and in particular anything that might require a hardware driver ?

Hello DBMandrake,

I was running the Turbo overclock (no overcurrent), the one below the normal one, I’ve changed it to Normal this morning but I’m not sure that is the issue though.

These are all the packages I have installed:
http://paste.osmc.io/iqusajosil.cmake (tvheadend is built from source, not the osmc one)

Some more info:
I have a some php scripts that run every 15 minutes
use iptables, bind and openvpn with some scripts but I haven’t been running this for a while and the freeze is unrelated.

I have a nat script at start up that enables nat and routing on the box so I can use this as a gw (mostly needed along with the Openvpn scripts) but works as a router even if no openvpn instance is running.
I also have squid setup, but I haven’t been using any of these things while testing the box for freezes, and last time it froze about 30 hours after boot.

I do monitor the box from a PRTG (monitoring tool) via snmp.

Hardware wise, only 1 out of the 4 ports are in use (I have a 12 ports self powered USB HUB) and I have the following attached to it:
USB Disk
USB Disk
USB Disk
Realtek RTL2832 (DVB-T) Adapter (working with tvheadend)

I think that’s it. Anything else you want to know let me know.

Thanks again for your help

Freeze seem to have stopped after setting over clock to normal. So that was possibly the issue, unless an upgrade fixed it.

A hard system freeze (completely unresponsive, can’t even ping the device) is usually due to too much overclock or too low a voltage.

If you’ve had no freezes since changing the speed to normal it will be that. By the way my own Pi 2 cannot run at Turbo reliably either - even with the official Raspberry Pi foundation power adaptor. It freezes at random within a few hours of boot at Turbo but is 100% reliable at Normal. Not all Pi 2’s can run at turbo.

It sounds like the issue I had, It has got to be turbo. I also have an original psu, so I thought I would be OK to run at turbo settings, obviously that’s not the case.

Not a biggy though, I am happy with the speed I get with normal settings on pi2, pi1 is sort of frustrating though so i’m only using pi2s for OSMC/Kodi.