Randomly blue/green tinted picture

Hello all,

I have the same issue with my new vero 4k and old 2009 Philips TV.

I did the upgrade but the issue still happens but it seems that ocurs less frequently. The message “This is a 2009 Philips TV which misreports colour caps” is not in the system journal. You can check it at http://paste.osmc.tv/upozixarub

Thank you so much for you work.


Thanks, Sam!

Sorry it took a few days to test, as I was out of town at a work conference.

I tried to run the update just now. It reached 69% and then PuTTY froze. Here is a screenshot of what it was doing when it froze: https://imgur.com/a/ps6Sg. Maybe it just lost the connection when the box restarted?

The log-files are uploaded at hppts://paste.osmc.tv/jixefifaqa

Sadly, I only had to watch TV for about 5 minutes, before the colour error showed up again.


ConnMan is restarted when network-osmc is updated.
As long as you don’t press Enter; the connection comes back naturally.

Anyway – it should all be updated now.

It looks like we’re not quite there yet however. I’ll take a look over the weekend and update this thread when there’s further things to test


Update: I’m getting a new TV tomorrow. It was past due anyway :slight_smile:

Thanks for the work you put into trying to help.



I’m still having the problem but I downgraded to the march version and it is working fine.

However, sometimes I have blinking black screen during playing videos or in the menu that are bit annoying. I don’t know if it is fixed in newer versions, do you know it?


Do you have an older Philips television? The problem is indeed not present in older releases of OSMC. I’m still eagerly awaiting a fix, some progress in identifying the problem has been made in this thread.

Yes, I have a 2009 Phillips TV. Thanks for the link.

By the way, do you have the black frames?

Indeed. 2009 Philips TVs are a pain in the backside.

This is still being worked on and I will update this thread when progress has been made


1 Like

I don’t have the black frames, sometimes a flash directly after turning the television on, but that because it’s negotiating the correct resolution I believe.

Hi, I’m having this exact same issue, with an older Philips TV (not sure of the year, but 2009 wouldn’t be surprising).

Is there likely to be a fix available for this before christmas?

If not, would that older march version of osmc likely work, as suggested above, and how would I downgrade to that version, and what would I be losing by using an older version like that?


We are working on some significant improvements, but I can’t guarantee it would be fixed by Christmas.

For legacy displays, you won’t lose much by using an older version of OSMC at this time. It can be downloaded from Download - OSMC. See Reinstalling OSMC - Vero 4K - OSMC



I believe this issue is now resolved and this will be included in the next update. It may indeed make it in just before Christmas.

I’ll add a Kodi option for this shortly so that editing via the command line is not necessary and let you know when this is ready for testing.


1 Like

Good news! Hopefully this will make it in just before Christmas.

1 Like

Indeed! Thanks for your patience


Hi, I’m suffering from the same problem:

Yesterday, I received my Vero 4k and immediately noticed the green tinted screen when setting up the device for the first time, exactly looking the same as in the pictures posted by Vaettur. I’m also experiencing green tinted screen when scrolling through the menus and when watching videos, irrespective of the video codec and source.

The Vero 4K is intended to replace my Raspberry Pi2 running on the current version of LibreElec (LibreELEC-RPi2.arm-8.2.1.). I have never experienced any green tinted screens on my Raspberry Pi2/LibreElec device.

The Vero 4K is connected to my Philips 32PFL9604H / 12 TV set. In order to eliminate the problem I also tried the HDMI cable previously used with Raspberry Pi and also different HDMI sockets at the TV set without any luck.

I also followed the steps in previous posts (“echo ‘rgb,8bit’ | sudo tee /sys/class/amhdmitx/amhdmitx0/attr” and extending “/etc/apt/sources.list”) without any luck.

Are there any news on when expect the issue to be fixed? I’m fearing to explain to my wife why I bought a new device when the existing device (the Raspberry) was working.

Best, Markus

This issue has already been solved. It will be in the update included on Sunday 7th January.

You can update in advance, but it may be best to wait if you’re not familiar with the command line.

You’ll need to add echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb to /etc/rc.local. In the future, we’ll make a GUI option available.


Thanks Sam. I added the line and it appears to work (so far).

b.t.w. where in the menu / settings are you going to place the GUI option?

Best, M

It won’t work persistently just yet, but will after Sunday’s update.

Probably under System -> Display.

Thanks Sam.

b.t.w. I really like the Vero 4K and OSMC. Very chic, stylish design and tremendously faster than my old Raspberry Pi2 with LibreElec. Nice work!

It was also quite easy to migrate all my userdate and add-ons from the old to the new device. I simply used the original Kodi backup add-on and a NAS to do the job (in case someone is interested).

Best, Markus

1 Like

Cheers – I hope you also enjoy OSMC as well. It is a little more open