Rasberry Pi 2 USB ports not working

Hi all,

I just got my RSPi2 a week ago and I cannot for the life of me get the USB Ports to work.
I have searched the forums and the internet exhaustively and either I am missing something, or my USB ports don’t work and I need to return this unit.
My connection at the moment is via ethernet and I have a 2.5a power supply.

My main objective is to get my Logitech K400 plus keyboard to work but not luck.
I even tried a direct direct connection of a Microsoft IntelliEye Keyboard/Mouse Combo… - The lights turn on, but no response on TV from keyboard
So for now all my control is through my Samsung tv Remote (CEC) and “Yatse” through my phone or Tablet.

Here are my reports:

osmc@osmc-Grumbole:~$ lsusb
Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

osmc@osmc-Grumbole:~$ dmesg
[ 2922.189814] usb 1-1.3: new high-speed USB device number 10 using dwc_otg
[ 2922.307539] usb 1-1.3: New USB device found, idVendor=148f, idProduct=5370
[ 2922.307576] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2922.307595] usb 1-1.3: Product: 802.11 n WLAN
[ 2922.307611] usb 1-1.3: Manufacturer: Ralink
[ 2922.307627] usb 1-1.3: SerialNumber: 1.0
[ 2925.779789] usb 1-1.5: new full-speed USB device number 11 using dwc_otg
[ 2925.895846] usb 1-1.5: New USB device found, idVendor=046d, idProduct=c52b
[ 2925.895885] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2925.895903] usb 1-1.5: Product: USB Receiver
[ 2925.895919] usb 1-1.5: Manufacturer: Logitech

Logs:

http://paste.osmc.io/dapopafeda.vhdl
http://paste.osmc.io/koluyemewi

I even installed tried “Solaar” but no luck.
Basically I want to know if the USB works or if I have to return the unit.

Can anyone help me?

thanks

gB.

As you said you are connected with Ethernet, how about you first try to get the keyboard working without the USB Wireless adapter plugged in to avoid any power issue.
Or a secondary check is you keep the Wireless Adapter plugged in unplug the keyboard and check if you can scan wireless networks (MyOSMC -> Network -> Wireless)
Did you ever the the colored square on the right top of your screen?

Addendum to fzinken post -
have you enabled the extra current available from the Pi2 (using max_usb_current)?
Derek

Hi and Thanks for the kind replies…

fzinken - There is not “Wireless” options in (MyOSMC -> Network -> Wireless) only the “Wired” option
Pulling all but the unified keyboard USB receiver made no difference either.
BTW, the keyboard works fine on my desktop… as I said even a regular wired keyboard did not work although it was listed under lsusb

dandnsmith - I have set (max_usb_current=1) it seems to make not difference

Do these errors have any relevance here?

[3.233474] systemd[1]: Breaking ordering cycle by deleting job kbd.service/start
[3.233491] systemd[1]: Job kbd.service/start deleted to break ordering cycle starting with basic.target/start
[3.421271] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)

There must be something really wrong there, even so your wireless stick is recognized you don’t have a wireless option
Can you as a first try put your overclocking to normal.

Reset Overclock to normal but wireless did not show.

I do remember that when I initially tried to SSH, the request was rejected by the Pi even though the SSH server was active. Stopping and restarting made no difference.
What worked was to deinstall and reinstall it, then it worked.

Perhaps I should do a complete reinstall of OSMC?

To be honest there are some much wired issues on your install that I would suggest a clean reinstall. And then do one step at a time. Maybe stay away from over-clocking for some time especially over-voltage is not suggested and also watchout which addon’s your are installing

Hello,

Firstly, thanks to Fzinken and dandnsmith for the help.

It turned out that a fresh install was what was needed… all is working fine now.
I used the disk image this time instead of the installer too.

Perhaps one of my addons previously installed was intended for Android not OSMC.
Anyway success and thanks